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INTRODUCTION

The question of which email client to use provokes almost as much
fervor as the Macintosh versus Windows debate. Some people are
passionately dedicated to Eudora, while others feel that Entourage,
Mailsmith, PowerMail, or any of a dozen other applications is the
Supreme Tool for electronic communication. And then there are
those who simply want to follow the path of least resistance, which
often means using whatever happened to come with their computer.

I have my own opinions on the matter, of course. I went through an
Emailer phase, then an Outlook Express phase, then Eudora, then
Entourage, and now Mail. I also worked at a company that used a
Microsoft Exchange server, so I used both Windows and Mac OS 9
versions of Outlook for my business email. And I’ve tried every other
email client that runs under Mac OS X at least briefly—not to mention
a wide range of Web-based email interfaces. Moreover, I’m an email
junkie by anyone’s definition. I use about ten email accounts regular-
ly; I often receive hundreds of messages a day (not counting spam!);
I subscribe to dozens of mailing lists; and I save almost every message
I send or receive. My email world is also highly automated, with more
filters, rules, and scripts than you can shake a stick at. In short: I have
high expectations for my email software. So it has come as a shock to
some of my geekier friends that of all the applications I could use, I
chose Apple Mail.

Early versions of Mail lacked some important features, leading many
Mac users to write it off as a lightweight application that no power
user would take seriously. Today, after several major revisions, Mail
has become a surprisingly powerful, customizable, and extendable
application that can make short work of managing even complex
email needs. And, of course, it’s included free with Mac OS X.

I’ll be the first to admit that Mail is far from perfect. It has some bugs;
there are also a few things it does poorly, and a few things it can’t do
at all. But the biggest problem with Mail is that its interface and
documentation give little guidance on how to accomplish tasks and
solve problems that occur frequently. I’ve written this ebook to do just
that: help you take control of Mail by explaining the things you won’t
learn by reading the Help.
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I’ve organized this ebook a bit differently from most other Take
Control titles, which step readers through specific tasks, such as
upgrading to a new version of Mac OS X or handling Mail’s Junk Mail
filter. Because I assume most readers of this ebook know the basics of
sending and receiving email when all goes well, I organized this ebook
by topic, and included topics that, in my opinion, most often cause
real-world confusion and problems. To solve these problems, you’ll
need both background information and concrete steps, and I’ve done
my best to provide both.

In order to keep the length of this ebook reasonable, I decided to limit
the number of topics. For the most part, I do not cover basic configu-
ration and usage topics that Mail’s built-in Help covers adequately.
However, I also gloss over (or omit entirely) discussion of some more
advanced topics, such as:

• Digital signatures and encryption

• Controlling Mail with AppleScript (including the Script menu)

• Using alternate text encodings and scripts (for multilingual
messages)

• Strategies for sorting, organizing, and finding filed messages

In addition, I wrote only four pages about rules—an important topic
that could easily fill another document this size. If you are interested
in an ebook about Mail’s rules, click here to let me know.

This ebook says little about junk mail. Because spam is such a big
topic, I’ve devoted an entire ebook just to spam: Take Control of
Spam with Apple Mail (http://www.tidbits.com/takecontrol/spam-
Apple-Mail.html).

Having read thousands of messages about Mail on various discussion
boards, I’m keenly aware that users have experienced a great variety
of problems—far more than I can address here. Future editions of this
ebook (or other Take Control titles) may include expanded coverage
of some of these issues.

In my testing, I used Mail version 1.3.9, which is included with Mac
OS X Panther versions 10.3.5 and higher. If you have an older version
of Mac OS X (and thus an older version of Mail), some of these in-
structions will not apply to you. I strongly recommend upgrading to

http://www.tidbits.com/takecontrol/spam-Apple-Mail.html
http://www.tidbits.com/takecontrol/spam-Apple-Mail.html
mailto:jwk@mac.com?Subject=I'd%20like%20a%20book%20about%20Mail%20rules
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the latest version of Panther if you can. Take Control of Panther:
Volume 1, from Peachpit Press, or my ebook Take Control of
Upgrading to Panther can help you with the upgrading process
(http://www.tidbits.com/takecontrol/panther/upgrading.html).

Terminology and Conventions
In reading this ebook, you may encounter a few unfamiliar terms
and conventions. To get the most out of this ebook, please note the
following:

• Path syntax: This ebook occasionally uses a path to show the
location of a file or folder in your file system. Path text is formatted
in bold type. For example, Panther stores most utilities, such as
StuffIt Expander, in the Utilities folder. The path to StuffIt
Expander is: /Applications/Utilities/StuffIt
Expander.

The forward slash at the start of the path tells you to start from the
root level of the disk. You will also encounter paths that begin with
a tilde (~), which is a shortcut for any user’s home directory. For
example, if a user named joe wants to install fonts that only he
can access, he would install them in his ~/Library/Fonts
folder, which is just another way of writing
/Users/joe/Library/Fonts.

• Finding Mail’s Preferences: I often refer to preferences in Mail
that you may want to adjust. To display Mail’s preferences (not to
be confused with the system-wide settings found in the System
Preferences application), choose Mail > Preferences. Within that
window, click a button at the top to display a pane with that cate-
gory of preferences. Instead of giving detailed directions each time,
I’ll refer to each pane using an abbreviated notation such as “go to
the Junk Mail preference pane.”

http://www.tidbits.com/takecontrol/panther/upgrading.html
http://www.amazon.com/exec/obidos/ASIN/0321287649/takecontroleb-20/ref=nosim/
http://www.amazon.com/exec/obidos/ASIN/0321287649/takecontroleb-20/ref=nosim/
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Using the Glossary
This ebook’s Glossary defines several email-related terms, which also
appear in the text of the ebook in blue, italic formatting. You can click
blue, italic text to move to the glossary page that defines it; you can
then return from the Glossary to where you were reading using a
menu command or keyboard shortcut, as noted in Table 1.

Table 1: How to Quickly Navigate to a Previous Point in This Ebook

Viewing
Software Menu Command Keyboard Shortcut

Adobe Acrobat 6 View > Go To > Previous View Command-Left arrow

Adobe Acrobat 5 Document > Go To > Previous
View

Command-Left arrow

Preview Go > Back Command-[

NOTE For more tips about reading this ebook online and for suggestions
about printing it, see Reading and Printing Tips.

Version 1.1.1 Change List
This minor update includes the following changes from version 1.1:

• A new sidebar, “Using Other Account Types,” that has info about
accessing Hotmail, MSN, and Gmail accounts using Mail

• A tip about working around a bug in which clicking Reply fails
to display a new window

• Details about a bug affecting rules that color-code incoming
messages

• Several minor typographical corrections
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Version 1.1 Change List
This update incorporates the following noteworthy changes from
version 1.0.1:

• Changes to reflect new (and improved!) behavior in Mail 1.3.9
(part of the Mac OS X 10.3.5 update). Key areas affected were POP
(Deleting messages on the server) and IMAP (Message deletion).

• A tip and an Appendix entry about Eudora Mailbox Cleaner, a
utility that helps you import information from Eudora into Mail.

• A dozen new screen shots to illustrate some of the procedures.

• Clarification that .Mac mail servers do not respond to ping queries.

• Added a procedure for saving “invisible” attachments sent from
Entourage 2001. See Attachments from Entourage 2001 Users.

• Clarifications to Problems and Quirks with Automatic Addressing.

• Clickable Links has additional information about including
clickable URLs in your outgoing messages.

• An additional comment about rules that contain many conditions.
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QUICK START TO CONTROLLING APPLE MAIL

You can read this ebook in any order you wish, though for best results
I recommend reading the background information on any given topic
before trying any of the specific techniques. Start with whichever one
of these categories seems most urgent to you.

Solve problems:

• See Problems and Solutions for an index to troubleshooting steps
located throughout this ebook.

Manage Mail setup:

• Learn how to import data into a new account and how to remove
an account in Account Setup; then take charge of Backing up and
Restoring Email.

• Discover the good, the bad, and the ugly about Mail’s handling
of incoming and outgoing email in Learn about Email Protocols.
Then apply your new knowledge to Fix Email Transfer Problems.

Read email:

• Confused about plain text, rich text, and HTML? Find out how
they relate to the display of received messages, and discover cool
tips for customizing the Viewer window. See The Viewer Window.

• Handle Incoming Attachments with ease.

Create email:

• Make sure your messages get to the right destinations by reading
Addressing Email.

• Learn how to choose and use the best format—plain text, rich text,
or HTML—in outgoing messages in Formatting Outgoing Email;
then find out how to put Quoted Text and Clickable Links in your
message, and how to handle Outgoing Attachments.

Make Mail work better:

• Get a grip on the organizational tools Mail provides. See Manage
Mailboxes, which describes not only how to manage mailboxes but
also how to repair broken ones.

• Get to the bottom of the mysterious Previous Recipients list. See
Handle Previous Recipients.
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• Let Mail do tedious filing and sorting for you! See Streamline Mail
with Rules.

• Download goodies to make Mail work even better. See Appendix A:
Software Sources.

• Keep blank messages out of your In box. See Appendix B: The
Shoot Blanks Script.
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PROBLEMS AND SOLUTIONS

Having trouble with Mail? This ebook contains solutions to quite a
few problems. Use these links to find answers:

• I can’t import email or addresses from my old email application.
See Importing Email and Importing Addresses.

• Messages stay on my POP server even after I delete them. See
Deleting messages on the server.

• Mail stalls when trying to download messages from my POP
server. See Can’t Retrieve POP Messages.

• Mail keeps asking me for my password, even though I know I
entered it correctly. See Password Problems.

• I can’t send any email! See SMTP Troubleshooting Checklist.

• An Entourage 2001 user sent me an attachment but it doesn’t
appear. See Attachments from Entourage 2001 Users.

• Messages seem to be missing from one of my mailboxes. See
Fixing a Damaged Mailbox.

• I want to delete a message without opening it. See Use (or Hide)
the Preview Pane.

• I can’t enter a clickable URL in my email. See Clickable Links.

• I can’t tell whether or not an image will appear in the body of a
message. See Sending Graphical Attachments.

• When I print a message, it comes out backward and upside-down.
See the tip, The Backward Printing Problem.

• I need to send messages in HTML format. See HTML Messages.

• Address completion is driving me crazy! See Automatic Address
Completion.

• All my incoming attachments are Read-Only! See Opening
Attached Files.

• I can’t create a rule that matches blank messages. See Appendix B:
The Shoot Blanks Script.
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ACCOUNT SETUP

I take for granted that you can enter basic account information—your
user name, password, server name, and so on—without detailed in-
structions. Importing email and addresses and removing accounts
are more likely to give you pause. Here’s a quick primer on these
more advanced topics.

TIP When setting up a new account, always fill in the Full Name field on
the Account Information tab of Mail’s Accounts preference pane. If
this field is blank, the Junk Mail filter may fail to identify spam ad-
dressed to that account.

Importing Email
Mail supports importing email from Entourage, Outlook Express,
Emailer, Netscape/Mozilla, and Eudora, as well as the standard
.mbox files used by Mail and numerous other applications. If you
want to import email from an application whose format Mail does not
support, check out Emailchemy (see Appendix A: Software Sources),
a utility that can convert almost any mailbox format into almost any
other mailbox format.

TIP If you’re moving to Mail from Eudora, skip Mail’s built-in importing
feature and instead use the free utility Eudora Mailbox Cleaner (see
Appendix A: Software Sources). In addition to being much faster than
importing, this utility handles attachments, nicknames, and filters—
all in one pass.

You can import email when you launch Mail for the first time, or
later. To import email later, choose File > Import Mailboxes and
follow the prompts.
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WARNING! Some email clients store attachments as separate files rather than
as part of the message. When you import messages that had attach-
ments into Mail, they contain links to these files stored on your hard
drive. If you delete the folder containing the attachments, though,
you lose them forever—and if you rename it or move the folder or its
contents, your links won’t work. So leave that folder in place if pos-
sible; if not, at least keep track of where it is. In the case of Eudora,
you can avoid this problem by using Eudora Mailbox Cleaner (see
Appendix A: Software Sources).

Importing Addresses
Although importing email is generally easy, addresses are a different
story. Mail doesn’t store email addresses itself, but instead relies on
the separate Address Book application. Address Book directly imports
contacts only in the vCard and LDIF formats, which leaves out many
popular email clients. (Choose File > Import > vCards or LDIF in
Address Book if your contacts happen to be in one of those formats.)
Fortunately for everyone else, Apple has filled the gap by way of an
AppleScript. Choose Import Addresses from Address Book’s Script
menu (the one with an icon that looks like a stylized S) to import
addresses from Entourage, Outlook Express, Palm Desktop, Eudora,
Emailer, or Netscape. (For Eudora users, an even better choice for
converting contacts is Eudora Mailbox Cleaner—see Appendix A:
Software Sources.)

If you used another program to store contacts, importing addresses is
a two-step process. First, export your contacts in tab-delimited for-
mat. Then, use the free Address Book Importer utility (see Appendix
A: Software Sources) to select the exported addresses and assign each
field in the file to a corresponding Address Book field.

Removing Extra Accounts
In the course of using Mail, you may find that your setup becomes
overcrowded with extra accounts. Or, in some cases, you may wish to
temporarily remove an account for troubleshooting purposes, even if
you intend to keep using it.
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If you remove an IMAP, .Mac, or Exchange account (see Learn about
Email Protocols for more info on account types), you delete only the
locally stored copies of your messages. Because the originals remain
on the server, you can see your messages again simply by adding a
new account with the same settings; all you lose is the time required
to download them again. But for POP accounts, which store all your
messages locally, removal is a more serious matter. So if you plan to
remove an account—especially a POP account—heed this warning:

WARNING! Removing an account in Mail permanently removes all stored email
for that account from your hard disk—including the In, Drafts, Sent,
and Junk mailboxes (but not any On My Mac mailboxes). If there’s
even the tiniest chance you may want to retrieve any stored messages
from that account later, either back up the account or (better yet)
copy the messages to a local mailbox before removing the account.

To remove an account, go to Mail’s Accounts preference pane. Select
the account you want to remove, click the – (minus) button at the
bottom of the window, and click Yes when the confirmation dialog
appears.

TIP You can temporarily disable an account without removing it alto-
gether. Disabling an account makes its mailboxes vanish from your
Mailbox list, and prevents Mail from checking it for new messages.
To disable an account, go to the Accounts preference pane. Select the
account you want to disable, click the Advanced tab, then deselect the
checkbox labeled Enable This Account and close the Preferences win-
dow. Be sure to click Save when prompted. To re-enable the account,
go back to the same place and select the Enable This Account
checkbox.
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BACKING UP AND RESTORING EMAIL

A number of years ago, my computer suffered a severe hard drive
crash that wiped out years of saved email. At that time, I had not yet
switched to IMAP, and I backed up my computer perhaps once a year,
so most of those messages were unrecoverable. The loss of data was
devastating, but the shame was worse: I knew better than to put all
my data in one basket, but I had done it anyway. I learned a valuable
lesson, and today I back up my email (along with the rest of my files)
religiously. If you back up your email properly, you can recover from
nearly any disaster; if you don’t, your chances are very slim. So please
get into the habit of backing up your email regularly.

You can back up email using Apple’s Backup application for .Mac
members, or Retrospect (Dantz, http://www.dantz.com/), or any of
a dozen other applications. You can also do it manually. Whichever
method you use, back up the following items:

• ~/Library/Mail: This directory contains all your mailboxes,
your rules, and your Junk Mail statistics file.

• ~/Library/Preferences/com.apple.mail.plist: This is
your Mail preference file, which includes all your account settings.

•  ~/Library/Application Support/AddressBook/
AddressBook.data: This file contains your Address Book data,
including your Previous Recipients list.

Be sure to copy these files to a volume other than the one where you
normally store them. Burn them onto a recordable CD or DVD or
store them on an external hard drive or network server; they’ll be
safer there in the event of a hardware failure. Back up your email as
often as you can—once a day is not too often.

TIP If your email contains sensitive or personal information (as it often
does), consider encrypting your backups. Otherwise, if your backup
media were lost or stolen, someone else could learn a great deal about
you! Retrospect, for example, offers a built-in encryption feature, or
you can use a separate utility such as PGP Personal Desktop (see
Appendix A: Software Sources).

http://www.dantz.com/
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If you need to restore backed-up email later, you can use either of
two methods. If you want to restore all your email and settings at
once (for example, after reinstalling Mac OS X), simply copy the files
back to their original locations, replacing files of the same name (if
any). On the other hand, to restore only a particular mailbox, choose
File > Import Mailboxes, select the Mail for Mac OS X radio button,
and select the appropriate mailbox (.mbox) file from your backup set.
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LEARN ABOUT EMAIL PROTOCOLS

Read this section to learn more about mail protocols and make sure
you are using protocols in a smart, trouble-free way.

Counterintuitively, receiving and sending email generally have noth-
ing to do with each other in terms of the protocols (and often the ser-
vers) used behind the scenes. I mention this because you may find
that you can receive email perfectly well but not send any—or vice
versa. If you understand how Mail handles sending and receiving,
solving problems becomes much easier.

Although you may not be aware of it, to send and receive email, you
actually have two email accounts: one for sending and another for re-
ceiving. Your two accounts may share the same user name and pass-
word, but that is typically the only formal relationship they have.

Your incoming account fetches email from your mail server and
delivers it to you using a mail delivery protocol—such as POP (Post
Office Protocol) or IMAP (Internet Message Access Protocol). Your
outgoing account uses a mail transfer protocol called SMTP (Simple
Mail Transfer Protocol) to send outgoing email from your machine to
your mail server, and then (usually through a number of intermediate
steps) to the recipient’s mail server.

NOTE All the mail protocols Mail supports offer the option of SSL (Secure
Sockets Layer) communication. SSL encrypts messages as they travel
from the mail server to your computer or from your computer to the
server, keeping them safe from hackers who could intercept network
traffic. However, an SSL connection affects only your computer’s
communication with your mail server; it does not protect a message
all the way from sender to recipient. For this, you must use Mail’s
built-in encryption feature (which this ebook does not cover) or a
third-party tool such as PGP or GPGMail. You can turn on SSL for
any incoming or outgoing account with a single checkbox, but many
mail servers don’t support SSL—check with your network adminis-
trator or ISP before turning on SSL.
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SIDEBAR USING OTHER ACCOUNT TYPES

If you use Hotmail, AOL, Yahoo! or another service to send and re-
ceive email, Mail may be able to access those accounts too—with a
bit of help.

Hotmail and MSN:

To give Mail the ability to check Hotmail or MSN accounts (using
the HTTPMail protocol), download the free HTTPMail plug-in. (See
Appendix A: Software Sources.) However, be aware that as of late
September, 2004, Microsoft discontinued Hotmail access via Desk-
top clients (including this plug-in and Entourage) for users with free
subscriptions. To continue using HTTPMail to check your Hotmail
account, you must upgrade to a paid subscription—either the $20
per year Hotmail Plus account or the $100 per year MSN Premium
account. This limitation applies to all new Hotmail users, and will
take effect for existing subscribers by April, 2005.

Yahoo!, Mail.com, and Another.com:

If you want to check Yahoo!, Mail.com, or Another.com Webmail ac-
counts, the proxy application MrPostman may do the trick. (Again,
see Appendix A: Software Sources for more information.)

Google Gmail:

Subscriber’s to Google’s Gmail service can retrieve their messages
with Mail using POP, though some of the settings are a bit out of
the ordinary. You must first enable POP access (see instructions at
http://gmail.google.com/support/bin/answer.py?answer=13273);
then set up a Gmail account in Mail (instructions located at
http://gmail.google.com/support/bin/answer.py?answer=13275).
Note that Gmail a subscriber account may be required to view these
Web pages.

AOL:

AOL now offers its members access to their email accounts using
IMAP. For setup details, see
http://members.aol.com/adamkb/aol/mailfaq/imap/.

http://gmail.google.com/support/bin/answer.py?answer=13273
http://gmail.google.com/support/bin/answer.py?answer=13275
http://members.aol.com/adamkb/aol/mailfaq/imap/
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POP
For years, having an Internet email account almost invariably meant
having a POP account. POP remains the default choice for many ISPs
and businesses, and every email client supports POP if nothing else.
In a nutshell, a POP account works like this: First, your client asks the
server for the list of messages in your In box, along with their sizes.
Then, depending on your client’s settings, it downloads all the mes-
sages, selected messages, or all messages under a specified size, to
your local machine. Finally (and optionally), your client instructs the
server to delete its copy of the messages. The server does not store
information about whether or not a message has been downloaded,
read, or deleted; only your local client knows these things. For this
reason, if you leave some messages on the server and then check your
email with a different client (or on a different machine), all the
messages will appear to be unread.

Deleting messages on the server
POP is a simple and straightforward protocol, but every client handles
deletions a bit differently. Mail handles deletions more differently
than most, and its failure to delete messages the way users expect has
been a source of much discussion. As you read the following, keep this
fundamental principle in mind: Deleting a message in Mail has
nothing to do with deleting a message on the server.

You determine how Mail deals with deleting POP messages on the
Advanced tab of Accounts Preferences:

• When Remove Copy from Server After Retrieving a Message is
deselected, every message you download remains on the server
indefinitely, regardless of whether you move it or delete it in Mail.
If enough of these messages accumulate, you may reach your mail
server quota, meaning that anyone who sends you email will re-
ceive a bounced message with a “mailbox full” error! Unfortunate-
ly, Mail shows no indication that you have undeleted messages on
the server; the only way to tell is to check your email with another
POP client. When messages remain on the server, Mail enables you
to delete them all at once by clicking the Remove Now button; you
can’t choose to delete some messages but not others.
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FIGURE 1

Choose when you want messages to be deleted from your POP
server using this pop-up menu on the Advanced tab of Mail’s
Accounts preference pane.

• When Remove Copy from Server After Retrieving a Message is
selected, a pop-up menu (see Figure 1) displays another set of
options. I recommend that you choose one of the “After…” options,
since those options work well and offer a bit of backup protection if
you accidentally delete an important message from your local disk.
Here’s more information about the options in the pop-up menu:

• Right Away: This option represents the original, standard
POP behavior—when Mail finishes downloading a message, it
immediately deletes the message from the server. This is the
cleanest setting as it prevents the possibility of duplicate mes-
sages. It’s also the least safe, because once that downloaded
message is deleted (intentionally or otherwise), it’s gone for
good.
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• After One Day, After One Week, After One Month: If
you want the security of knowing your original message is still
on the server for a while after downloading it, choose one of
these options. But be aware that the server doesn’t store the
deletion schedule; Mail does. Regardless of what you set here,
the messages will remain on the server until the first time this
particular copy of Mail checks that account after the designated
interval has elapsed. In other words, if you choose After One
Day, then go on vacation and check your email remotely a week
later, your messages will still be there.

• When Moved from Inbox: Selecting this option should do
what it says—delete messages from the POP server when you
either file them in a local folder or delete them from your local
In Box. For many people, this sounds like the most logical way
to delete email. Unfortunately, this setting doesn’t work exactly
the way you might expect—although it seems possible that
Apple will fix it in a later version. With When Moved from
Inbox selected, you can move a message to a local mailbox
or even delete it…but the message remains on the POP server
(and therefore reappears if you check your email using another
client). The message is finally deleted after you quit Mail,
relaunch it, and then check your email in that account again.
(Checking your email again without quitting doesn’t do the
trick, nor does changing the settings on the Special Mailboxes
tab of Accounts Preferences.)

Deleting local messages
In addition to the POP-deletion server settings that I discussed just
previously, you can change how Mail deletes local copies of messages
using the Special Mailboxes tab of the Accounts preference pane (see
Figure 2). You have two choices:
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FIGURE 2

To configure if and when local copies of messages are deleted, use
the controls in the Trash section of the Special Mailboxes tab of
Mail’s Accounts preference pane.

• If the checkbox Move Deleted Messages to a Separate Folder is
selected, deleting a message sends it to a (local) Trash mailbox;
Mail deletes it for good at the time you specify in the pop-up menu.
This option helps to prevent a bloated Trash mailbox, but keep in
mind that it doesn’t warn you before removing deleted messages at
the scheduled times.

• If that checkbox is deselected, deleting a local message merely
hides it. (To toggle the display of these deleted messages, choose
View > Hide Deleted Messages or Show Deleted Messages.) To
delete these messages for good, select your POP account in the
Mailbox list and choose Mailbox > Erase Deleted Messages > In
Selected Mailbox (Command-K). If you frequently find yourself
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undeleting messages you’ve previously deleted, this option makes
it somewhat easier to locate them.

IMAP
By way of full disclosure, I should mention two things. First, I am
deeply, passionately committed to IMAP and would never use POP
again if I could get away with it. And second, I converted reluctantly:
for a long time I resisted IMAP, thinking it was weird, annoying, and
pointless. Only after a POP-related tragedy and weeks of experiment-
ing with IMAP did I finally see the light. So I come by my enthusiasm
honestly; if you will forgive my evangelistic fervor for a few para-
graphs, I’m going to tell you what IMAP is, why it’s a good thing, and
why you should consider using it. But I’ll also mention some ways in
which Mail makes IMAP less of a joy than it should be.

How IMAP works
From a user’s point of view, the primary distinction between POP and
IMAP is that in an IMAP account, all your messages stay on the mail
server even after you have downloaded and read them. As with POP,
you can file your message into mailboxes, but an IMAP account stores
all those mailboxes on the server as well. IMAP supports server-side
searching, meaning your client can ask the server to search your
saved messages even if you don’t have a local copy of them. (Mail,
unfortunately, does not support server-side searching; it must down-
load and index IMAP messages before searching them.) In addition,
the server—not your local client—keeps track of which messages you
have read, forwarded, or replied to, so such status indicators appear
correctly even if you check your email from another machine. You
can, of course, delete messages you no longer want in order to free
space on the server. But unlike POP, IMAP gives you the option of
marking messages for later deletion without moving them to a sepa-
rate Trash mailbox.

The main advantage of IMAP is that you can view your email using
any client, on any computer (or platform), and you will always see
exactly the same thing. This means that if you check your email from
a second computer or an Internet café, all your messages will be
there—including sent and saved messages. It means that even if you
use just one computer, you can switch or upgrade mail clients at any
time—or use several at once, for that matter—without ever having to
export, import, or convert email messages. And it means that if you
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lose local messages due to a hard drive crash, disk error, theft, fire, or
whatever, all your email remains safe on the server.

Some people incorrectly assume that because IMAP keeps your email
on the server, you can access your messages only while connected to
the Internet, making it a seemingly unattractive option for mobile
users or those with dial-up Internet access. But you can set Mail (or
pretty much any IMAP client) to download all your messages just as it
would for a POP account so that you have a complete, local copy of
your email as well. You can then work with your email whether you’re
connected or not. Another misconception is that IMAP is basically the
same as the POP option of leaving email on the server after down-
loading it. But that option doesn’t store any metadata (such as a
message’s read status) or allow you to organize your messages into
mailboxes on the server.

NOTE Most (but not all) IMAP servers enable you to create multiple levels
of nested mailboxes—for example, you could have a mailbox named
Lists to hold messages from mailing lists, with separate mailboxes
inside for each individual list. Mail supports hierarchical mailboxes
if your server does, but it can’t override the server’s capabilities. Be
aware, however, that IMAP servers do not permit additional mail-
boxes within the In box.

Many large businesses and educational institutions use IMAP because
it permits their users to freely move between machines. For the same
reason, Apple’s .Mac service uses a form of IMAP for email, as do
Microsoft Exchange servers.

IMAP has only two major drawbacks, which may or may not be sig-
nificant, depending on your situation. First, most IMAP mail servers
impose a limit on the volume of email users can store. If you have
more email than your account can accommodate, you’ll have to move
some of it into local mailboxes, at which point those messages will
behave as though they were downloaded from a POP account, mean-
ing they won’t be available from any other computer. And second,
because IMAP operations happen on a server, it can sometimes take
longer to copy or file an IMAP message than a POP message.
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WARNING! If you’re using IMAP, pay attention to your ISP’s mail server backup
policies. If the email stored on the server is not backed up frequently
(and easily restorable in the event of a major problem), be sure to
keep local copies of all your messages and back them up yourself
(see Backing up and Restoring Email).

You may be unaware that some mail servers allow both POP and
IMAP to be used for retrieving email from the same account. This is
the default setting, for instance, on Mac OS X Server. If you currently
access your email using POP, try adding a second account with identi-
cal settings, except for an account type of IMAP. If it works, you can
remove your POP account and (if you wish) copy mailboxes full of
locally stored messages onto the IMAP server. If it doesn’t work, con-
tact your ISP to see if they can turn on IMAP as an option. In some
cases, this may require you to set up an entirely new email account.
On rare occasions, an IMAP account may require an additional fee.
If your ISP doesn’t offer IMAP and you’re interested in switching to
one that does, you can find a list of providers here:
http://www.ii.com/internet/messaging/imap/isps/#providers.

TIP AOL via IMAP: AOL now offers its members access to their email
accounts using IMAP. For setup details, see
http://members.aol.com/adamkb/aol/mailfaq/imap/.

Mail’s IMAP annoyances
As much as I like IMAP, I should be clear that all IMAP clients are not
created equal. Mail, in particular, has quirks in its handling of IMAP
that can frustrate you if you have used IMAP with other email clients
and therefore aren’t prepared to think about email the way Mail
wants you to.

Subscriptions
Mail has no concept of subscriptions. Most IMAP clients enable you
to subscribe to stored mailboxes individually. Only those folders
you’ve subscribed to appear in your Mailbox list. If you have many
folders, not all of which you need to use on a regular basis, Mail’s
inability to “unsubscribe” may be annoying. This is especially true if
your mail server uses hidden mailboxes (prefixed with a period) to
store account information, or if you choose to download local copies

http://www.ii.com/internet/messaging/imap/isps/#providers
http://members.aol.com/adamkb/aol/mailfaq/imap/
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of all your messages and keep them synchronized with the server—the
more folders, the longer this takes.

Message deletion
Mail 1.3.9 handles IMAP message deletion much better than earlier
versions did, though if you’re accustomed to using other IMAP
clients, you may still find Mail’s behavior to be somewhat un-IMAP-
like. Normally, when one “deletes” an IMAP message, the client
leaves the message in place and simply changes a flag on the server
that marks the message for later deletion. The client may display the
deleted messages (often in a strikethrough style) or enable you to hide
them. When you wish—manually or on a schedule—you can tell the
server to expunge the messages marked for deletion, deleting them
for good.

By default, Mail prefers to move deleted messages to a Trash mailbox
on the server instead of marking them for deletion (parallel to the way
files are deleted in the Finder). This makes sense for many users, but
if you prefer a more orthodox IMAP behavior, you can simply change
a couple of settings:

• On the Special Mailboxes tab of Mail’s Accounts preference pane,
deselect the Move Deleted Messages to the Trash Mailbox check-
box. Then choose View > Show Deleted Messages to display the
deleted messages (in light gray) or View > Hide Deleted Messages
to hide them.

• In Mail, the “expunge” command is Mailbox > Erase Deleted
Messages > account-name. Mail does not have an option to
expunge deleted messages on a schedule; if you want that behav-
ior, leave Move Deleted Messages to the Trash Mailbox selected
and choose your desired deletion schedule from the pop-up menu
labeled Permanently Erase Deleted Messages When.

There’s one thing about Mail’s IMAP deletion behavior that you
may find confusing. Let’s say you set up a new IMAP account in Mail,
keeping the default setting, Move Deleted Messages to the Trash
Mailbox. And let’s assume that you already had a Trash mailbox on
the server, which you named (very sensibly) Trash. Mail places a new
mailbox under Trash in the Mailbox list bearing the name of your ac-
count, and this is where it moves deleted email messages. So far so
good…except this isn’t your existing Trash mailbox. You’ll still see a



Page 26

mailbox in your IMAP account named Trash, but no new messages
appear there.

What’s going on? Well, Mail created a new “Trash” mailbox for you
named Deleted Messages. That’s right: even if you already have a
mailbox named Trash on your IMAP server, Mail ignores it; the Move
Deleted Messages to the Trash Mailbox setting by default uses a mail-
box named Deleted Messages! (The same is true, by the way, for sent
messages; if you store them on the server, Mail makes a mailbox
named Sent Messages and uses that to store sent email, even if you
already had a mailbox named Sent.) To switch to your original Trash
mailbox, you must select it in the Mailbox list and choose Mailbox >
Use This Mailbox For > Trash, and then delete the Deleted Messages
mailbox.

.Mac
For the most part, everything I said just previously about IMAP
accounts is also true of .Mac accounts. In fact, you can use any IMAP
client—not just Mail—to connect to your .Mac account. The only
surprising (and surprisingly little-known) thing about .Mac accounts
is that you can also access them using POP if you wish. To do so,
simply set up a new POP account, entering mail.mac.com as both
the incoming and outgoing mail server. In the User Name field, enter
just the portion of your mac.com address before the @ sign.

TIP .Mac accounts offer a unique feature: the capability to include your
photo in outgoing messages. You don’t use Mail to select the photo,
though; you must log into your .Mac account with a Web browser,
click the Preferences icon, and upload a photo there. Then the .Mac
mail server automatically inserts your photo in a special header that
is visible only if the recipient uses Mail or the .Mac Web interface.

Exchange
If your copy of Mail connects to a Microsoft Exchange server (or if
you would like it to), you can work more effectively if you know some
background information about Exchange.

Microsoft Exchange servers provide email, shared calendars, and
a variety of other network services to many organizations. Under
Windows, Outlook is the application of choice for working with
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Exchange-based data. Although Microsoft created a version of
Outlook for Mac OS 9, they chose not to port it to Mac OS X, and
instead, added (limited) Exchange support to Entourage. While ter-
rific for Entourage users, this seemingly meant that Mac users could
access their Exchange-based email only by spending money on a
commercial application. But then Panther’s updated version of Mail
solved the problem by adding Exchange support…or did it?

When is Exchange not Exchange?
I’m going to let you in on a little secret: Mail doesn’t really support
Exchange accounts as such. Exchange servers have always used a
proprietary protocol, called MAPI, for transferring email and other
data. Several years ago, though, Microsoft added an optional feature
that server administrators can turn on to provide access to email via
the IMAP protocol as well. Mail uses IMAP, not MAPI, to access your
Exchange-based email; this works only if your organization’s
Exchange server has IMAP support enabled. Even then, you get
access to just a subset of the information in your Exchange account,
because Mail doesn’t have nearly as many features as Outlook does.
Nevertheless, something is better than nothing, and many users find
this level of Exchange support perfectly adequate.

The only way to know whether your organization’s Exchange server
supports IMAP is to ask your IT department; they can also tell you
how to fill in your user name, domain, and other settings (which are
often different from what you may expect with regular POP or IMAP
accounts). If your organization has not enabled IMAP support for its
Exchange server, you can ask them to do so. But I must warn you
from personal experience that you are likely to meet with resistance.
Although turning on IMAP is fairly easy, some organizations feel it
poses a security risk or increases the difficulty of providing support.

Exchange vs. IMAP
If Mail supports Exchange servers only using IMAP, you may well
ask, “Why offer Exchange as a separate account type? What’s the
difference?” Both IMAP and Exchange account types use IMAP, but
Exchange accounts have a subtle difference: they filter out everything
except email.

In other words, the online mailboxes Exchange uses for Calendar,
Contacts, Notes, Tasks, and so on do not appear in the Mailbox list
when the account type is Exchange, and in addition, messages other
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than conventional email (notably meeting invitations) never appear
in your In box. If you connect to the very same server with an account
type of IMAP, on the other hand, all these items (and more) appear in
your Mailbox list (see Figure 3).

FIGURE 3 You can use either an Exchange
account type or an IMAP account
type to access an Exchange account.
In this example, both “Exchange”
and “Exchange via IMAP” refer to the
very same account. The IMAP version
displays additional mailboxes, allow-
ing you to access some information
that the Exchange version does not.

This may seem backward; why should choosing Exchange give you
less information from your Exchange server than IMAP? Apple’s
rationale is that because Mail does not have integrated calendar and
contact features, showing mailboxes and messages you can’t use
amounts to unnecessary clutter. However, you can use some of the
filtered content, such as meeting requests—or you could, if you could
see it. In other words, for Exchange users, the IMAP account type is
often the better choice. You lose nothing and gain access to informa-
tion that would otherwise be hidden.
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TIP If you specify an IMAP account type, you’ll be able to see Outlook
meeting invitations; they appear as meeting.ics files attached to
email messages. If you’re an iCal user, you can double-click one of
these files to add the meeting to your iCal calendar and optionally
send a confirmation to the meeting organizer.

SMTP
Every account type Mail supports uses SMTP for delivery of outgoing
email. In most cases, you can simply enter the server information
provided by your ISP and not have to think about it again. However,
if you encounter problems when sending email, you may have an
SMTP-related problem.

Many SMTP-related problems come from efforts that ISPs take to re-
duce spam. For instance, most ISPs have taken measures to make it
harder for unauthorized users to send email through their systems.
The unfortunate side effect for upstanding netizens is that you may
find your efforts to send legitimate email blocked, too.

Port blocking
Some ISPs configure their routers to block port 25, the “channel” mail
servers usually use to communicate with each other. When this oc-
curs, Mail can use port 25 to connect to SMTP servers within the net-
work of the ISP currently providing your Internet access, but not to
any SMTP server outside their network. That way, the ISP can verify
that you, the sender, are a legitimate account holder and not some
random ne’er-do-well trying to hijack their mail server. Here are two
of the most common port-blocking scenarios:

• .Mac blocked by cable-modem or DSL provider: If you have
broadband Internet access at home, you may be able to send email
messages using your provider’s server (for example, smtp.my-
cable-company.com) but receive error messages when you try
to send email using your .Mac account (smtp.mac.com).

• Home ISP blocked by remote network: If you take your
PowerBook or iBook to a library, Internet café, airport, or hotel
and connect to the Internet using their (wired or wireless) net
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work, you may be unable to send email using the mail server of the
ISP that provides your account at home, even though you changed
no settings.

In such cases, your best strategy is to switch to an outgoing mail ser-
ver that accepts email from your current connection. Alternatively, if
your account offers Web-based access, you may be able to send email
using your Web browser as a short-term workaround.

Port-Blocking Problems in “Fix Email Transfer Problems,” ahead, has
further details and steps you can follow to deal with port blocking.

SMTP authentication
Another layer of SMTP complexity involves authentication, a fancy
term for verifying your user name and password. Even though you
can connect to a given SMTP server on port 25, that server may still
require that your email client send it a valid user name and password
before it will accept email for delivery. An SMTP server may also
check that the From address belongs to a valid user on its system;
this reduces spoofing (sending email with forged headers so that it
appears to come from someone else’s address). If you do not wish the
recipients to reply to you at the From address a particular server re-
quires you to use, you must use the Reply-To field to specify where
replies should go (see Hidden Address Fields).

If you experience problems with sending email that you suspect may
be related to authentication, read Authentication Errors, later.
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FIX EMAIL TRANSFER PROBLEMS

The previous section, Learn about Email Protocols, described several
issues you may experience with POP and IMAP accounts and explain-
ed why they exist and what you can (or cannot) do about them. How-
ever, sometimes—even with optimum account settings— Mail runs
into other kinds of problems while transferring email. (For what it’s
worth, anecdotal evidence suggests that Mail is more prone to
problems when checking POP accounts than IMAP accounts.)

Incoming Email Troubleshooting Checklist
If you cannot make Mail download incoming messages, use the
following steps to diagnose and solve the problem. The first two items
pertain to very specific (and common) symptoms:

1. Mail stalls while downloading POP messages: Sometimes
downloading simply takes a long time, but if Mail stalls for several
minutes, you may have a damaged message in your In box. See
Can’t Retrieve POP Messages.

2. You see error messages about your password being
rejected: Find help in Password Problems.

TIP If you want to see what Mail is doing behind the scenes, choose
Window > Activity Viewer. A small floating window appears, display-
ing more detail about each activity Mail is performing at the moment.
To cancel any task, click the red “Stop” button next to it.

If your problem fits into neither of those categories, continue with
the following steps:

3. Check your Internet connection: Visit your favorite Web site
to make sure your computer can access the Internet. If it cannot,
the problem relates to a failed Internet connection. If it can, con-
tinue with the next step.

4. Verify that your account is online: If Mail cannot connect
to an account after multiple attempts, it may take the account
“offline”—which means that Mail stops trying to connect for that
account. You can tell an account is offline if the account name ap-
pears dimmed in the Mailbox list, with a “squiggle” symbol next to
it. To reestablish connection, click the squiggle symbol, or choose
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Mailbox > Online Status > Take Account-Name Online (or Go
Online to take all accounts online). If the account remains offline,
continue to the next step.

5. Check mail server availability: Mail servers occasionally crash
or become unreachable due to network problems. If an account
remains offline even after choosing Go Online, check your server
by pinging it. To do so, open Network Utility (you can find it in
/Applications/Utilities), select the Ping tab, enter the
domain name or IP address of your mail server, and click Ping
(Figure 4).

FIGURE 4

The Ping tab in Network Utility can tell you whether your mail
server is alive and well.

If you see a series of messages along the lines of “64 bytes from
xxx.yyy.zzz.xxx: icmp_seq=0 ttl=64 time=3.309 ms,” your mail
server is responding and you should continue to the next step. If
not, contact your ISP to see if there’s a problem.
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NOTE This test proves only that the machine is online, not that the mail
server software is running—though usually the former implies the
latter. Also, be aware that not all servers respond to ping messages—
mail.mac.com, for instance, does not. It’s a good idea to run a ping
test when you know the server is working, in order to establish a
baseline.

6. Verify your SSL setting: Some POP and IMAP servers support
SSL, some don’t. If in doubt, leave the SSL checkbox deselected;
it’s located on the Advanced tab of the Accounts preference pane.

7. Try a new user: Create a new Mac OS X user account using the
Accounts pane of System Preferences. Log in as the new user (you
can use Fast User Switching, if you wish) and configure Mail to
check the account experiencing problems. (See Kirk McElhearn’s
Take Control of Users & Accounts in Panther for more
information on setting up and using a troubleshooting account
http://www.tidbits.com/takecontrol/panther/users.html.) If it
works, one or more of Mail’s preference, mailbox, or support files
may be damaged.

To solve the problem, your best bet is to back up all your email
(see Backing up and Restoring Email), delete all potentially
problematic files, and reconfigure Mail from scratch. The files
you should delete are:
~/Library/Preferences/com.apple.mail.plist and
~/Library/Mail (entire folder). After reentering your Mail
settings, you will also need to restore (or import) your mailboxes,
as described under Backing up and Restoring Email.

8. Try another client: If all else fails, try another email client (see
Appendix A: Software Sources). If it works, Mail may have a bug
that interferes with email retrieval. Check the Apple Web site for
updates or advice. If another client has the same difficulties, con-
tact your ISP to see if they know of any server problems.

You should now be able to retrieve your incoming email.

Can’t Retrieve POP Messages
If Mail stalls while downloading email from a POP server, the likely
cause is a damaged or severely malformed message—which may

http://www.tidbits.com/takecontrol/panther/users.html
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sometimes appear to be completely blank. (In virtually every case,
such a message is spam; in fact, I believe that some spam is designed
expressly to cause Mail to fail.) You solve the problem by deleting the
specific message causing the problem. This “unclogs” Mail, allowing
messages queued behind it to flow to your In box. Unfortunately, Mail
has no way to tell a POP server to delete a message it has not yet
downloaded, but you can work around this problem in any of the
following ways:

• If your POP account also offers IMAP access, set up a new IMAP
account in Mail with the same user name, password, and incoming
mail server as your POP account. Check your email with the IMAP
account and delete the problem message. Then choose Mailbox >
Erase Deleted Messages > Account-Name. (Later, you can
remove—or disable—this temporary account. See Removing Extra
Accounts, earlier.)

• If your POP account offers Web-based access, log into your
account with your favorite Web browser and delete the problem
message there.

• If your account is POP-only, you could use another POP client,
such as Eudora, to check your email and delete the problem mes-
sage. You must be careful, however, to leave legitimate messages
in your In box so that Mail can retrieve them later. In Eudora, use
the following procedure. Choose Eudora > Preferences and click
the Checking Mail icon on the left. Select the checkbox labeled
Leave On Server For and enter a number (say, 7). Also select the
next checkbox, Delete from Server When Emptied from Trash.
Now, check your email, delete the offending messages, and choose
Special > Empty Trash. Check your email a second time to remove
the deleted messages from your server’s In box. Finally, quit
Eudora, return to Mail, and check your email again as usual.

TIP Eudora, available from http://www.eudora.com/, can be used free in
Sponsored or Light mode. A highly capable email client in its own
right, it’s also a handy tool for Mail users who run into occasional
problems.

http://www.eudora.com/
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Password Problems
If you enter your password on the Account Information tab while set-
ting up an account, Mail automatically stores the password in your
Keychain (which is usually what you want). If, for security reasons,
you prefer for Mail to prompt you for your password each time you
connect, leave the Password field blank.

Sometimes, even after successfully checking your email many times
with the password you entered, Mail displays a dialog claiming that
the mail server has “rejected” your password. (This occurs most often
with .Mac and POP accounts, but every account type is susceptible to
this problem.) Worse, you may re-enter your password—and even se-
lect Remember This Password in My Keychain—but find that another
error message pops up as soon as you click OK. This annoyance may
be due to any number of causes, such as these:

• Mail may be exceeding a limit on the number of simultaneous
connections set by your mail server. This occurs most often when
you check your email using more than one client, or on more than
one machine at a time—though under some circumstances, Mail
may attempt to open a second connection to a mail server before
closing an earlier one. IMAP supports multiple simultaneous con-
nections, whereas POP does not. But even IMAP servers may balk
if you have too many connections at once; by rejecting your pass-
word, they prevent additional connections.

• Your Keychain—or more specifically, the password for this email
account stored there—may be damaged.

• Your ISP may be having difficulties with their mail server, or they
may have changed a setting on your account inadvertently. (This
happens more often than you might think.)

If Mail suddenly begins prompting you for your password repeatedly,
try these steps in order until the problem goes away:

1. Click Cancel, then check your email again in a minute or two.
Sometimes the problem goes away on its own. (If your account is
offline, choose Mailbox > Online Status > Go Online to connect
again and check email in the account.)

2. Check your Keychain. To do so, open Keychain Access, found in
/Applications/Utilities. Choose Window > Keychain First
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Aid. Click the Repair radio button, enter your administrator pass-
word, and click Start. If the Keychain file had an error (such as a
duplicate or malformed entry), Keychain First Aid can fix it.

3. If the problem persists, return to Keychain Access. Locate your
mail server in the list (in the case of a .Mac password, the entry
will be your .Mac username), select it, and click the Delete button.
The next time you check your email, you’ll see another dialog ask-
ing for your password; enter it and select Remember This
Password in My Keychain; then click OK.

4. If even that doesn’t work, your mail server may be at fault. Try
connecting and checking your email with another client applica-
tion (see Appendix A: Software Sources for suggestions). If the
other client also gives you error messages, ask your ISP for help.

SMTP Troubleshooting Checklist
If Mail displays an error dialog similar to the one shown in Figure 5
when you try to send a message, you have an SMTP-related problem.
If you have multiple accounts set up in Mail, you can try to solve the
problem by choosing a different server from the Send Message Using
pop-up menu and clicking Use Selected Server—but for a variety of
reasons that doesn’t always work. Besides, if you do that, you’ll see
the same dialog again the next time you try to send a message. It’s
better to look for, and address, the cause of the problem.

FIGURE 5

A dialog like this one indicates that Mail cannot communicate with
your SMTP server. The text of the error does not, however, always
indicate the exact nature of the problem.

Unfortunately, the error messages Mail displays regarding outgoing
email don’t always give enough information to tell what the problem
is or how to solve it. As you know from the SMTP discussion earlier,
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most problems with sending email occur because of anti-spam safe-
guards implemented by your ISP. If Mail complains that it can’t send
a message, don’t panic. Click the Try Again Later button, and then
check each of these items in order:

1. Check your Internet connection: Visit your favorite Web site
to make sure your computer can access the Internet.

2. Check SMTP server availability: If you get an error message
like “The server ‘smtp.domain.com’ refused to allow a connection
on port 25,” it could mean your SMTP server is offline. To check,
ping it. Open Network Utility (in /Applications/Utilities),
select the Ping tab, enter the domain name or IP address of your
SMTP server, and click Ping (see Figure 4, a few pages back).

If you see a series of messages along the lines of “64 bytes from
xxx.yyy.zzz.xxx: icmp_seq=0 ttl=64 time=3.309 ms,” your SMTP
server is responding, and you should continue to the next step. If
not, contact your ISP to see if there’s a problem.

NOTE This test proves only that the machine is online, not that the mail
server software is running—though usually the former implies the
latter. Also, be aware that not all servers respond to ping messages—
mail.mac.com, for instance, does not. It’s a good idea to run a ping
test when you know the server is working, in order to establish a
baseline.

3. Verify your authentication setting: See Authentication
Errors, ahead, for more information.

4. Verify your SSL setting: Some SMTP servers support SSL,
some don’t. If in doubt, leave the SSL checkbox deselected; it’s
located on the Advanced tab of the Accounts preference pane.

5. Check to see if port 25 is blocked: See Port-Blocking
Problems for details.

6. Make sure your account is set to use the right SMTP
server: See Purge SMTP Settings for details.

7. Try another client: If all else fails, you could be looking at a bug
in Mail (yes, it happens!). Try sending email with another email
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client. If it works, Mail may be broken. If not, contact your ISP to
see if they know of any server problems.

In the vast majority of cases, one or more of these steps should have
made it possible for Mail to send messages again.

Port-Blocking Problems
If the network to which your computer is connected blocks port 25,
you can take one of several steps to work around the problem and
send email. If Mail displays an error message such as “Refused to
allow a connection on port 25,” that’s a pretty good indication that
port 25 is blocked. However, port blocking could cause a number of
other error messages. The best way to tell for sure is to check using
Terminal. To see if port 25 is blocked, follow these steps:

1. Open Terminal (in /Applications/Utilities).

2. Enter the following (even if the SMTP server you’re trying to reach
is not smtp.mac.com):

telnet smtp.mac.com 25

and press Return. If you see something like the following, then
port 25 is not blocked:

Trying 17.250.248.48...

Connected to smtp.mac.com.

Escape character is '^]'.

220 smtp.mac.com ESMTP Service

However, if the “Connected” line never appears, port 25 is blocked.

3. Enter quit to end the telnet session, and then quit Terminal.

You now know whether port 25 is blocked. If it isn’t, skip ahead for
other possible causes and solutions. If it is, follow these steps:

1. Determine the SMTP server address for the network to which your
computer is connected. If your connection is through a dial-up or
broadband ISP, check the support section of the ISP’s Web site or
call their technical support department to get this information. If
your connection is through a corporate or university network, a
commercial wireless service, or another private provider, you may
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need to ask a system administrator for this information. While
you’re asking, check whether the SMTP server requires authentica-
tion and/or SSL. If you can’t find anyone to ask, a good guess is
smtp.domain-name.com (or mail.domain-name.com), where
domain-name.com is the domain name of the organization
providing your Internet access at the moment.

2. Go to the Account Information tab of the Accounts preference
pane. In the Accounts list, select the account from which you want
to send email. Click the Server Settings button at the bottom of the
window, and enter the domain name or IP address of the SMTP
server for your current network in the Outgoing Mail Server field.
If the server requires authentication, choose Password from the
Authentication pop-up menu (unless the organization specified a
different authentication method), and enter your user name and
password in the appropriate fields. Only if required, select the SSL
checkbox. Click OK, and then close the Preferences window.

3. Try sending yourself a message. If you receive it, you’ve solved the
problem. If not, make sure the address from which you’re sending
the message (as specified in the Account pop-up menu at the top of
the message window) is a valid email address for the network to
which you’re connected. If even that fails, you may need to change
the authentication method (see Step 2).

4. If you’re still unable to resolve a port-blocking problem, you may
be able to log into your email account with a Web-based interface
and use that to send email as a temporary workaround.

TIP There is yet another way around port blocking: use a different port!
The only catch is that your ISP’s mail server must also have the alter-
nate port turned on—some do, many don’t. Check with your ISP to
see if they offer SMTP access on another port, such as 2525. If they
do, go to the Account Information tab of the Accounts preference
pane, click Server Settings, and enter the port number in the Server
Port field.

You should now be able to send email using your current network. (If
you later change your network connection to its earlier setting, you
may need to switch your SMTP server back, too. To do this, return to
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the Accounts preference pane and select your old SMTP server from
the pop-up menu at the bottom of the window.)

NOTE If you’re away from your home network and find that port 25 is
blocked, you may be able to circumvent the problem by using a VPN
(virtual private network) connection to your corporate or school
network. A VPN sends network traffic through a secure “tunnel” to
another network, bypassing any port-blocking restrictions. Your
system administrator can tell you if VPN access is available; see Mac
Help for information on configuring Panther’s built-in VPN client.

Authentication Errors
When Mail encounters an authentication problem, it usually tells you
so fairly clearly—you’ll see an error dialog similar to the one shown in
Figure 6. Here are some common errors and solutions:

FIGURE 6

When you see a dialog like this one, it means Mail has encountered
an authentication error. The text of the error can give you impor-
tant clues to solving the problem.

• The server response was: Authentication required: Your
server requires authentication, but Mail is not set to use any. Go to
the Account Information tab of the Accounts preference pane, click
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the Server Settings button, and choose Password from the Authen-
tication pop-up menu. Enter your user name and password, and
try again.

• The SMTP server “smtp.domain.com” doesn’t support
authentication: You selected an authentication method but you
don’t need one. Go to the Account Information tab of the Accounts
preference pane, click the Server Settings button, and choose None
from the Authentication pop-up menu.

• The SMTP server “smtp.domain.com” doesn’t support
some-kind-of authentication: You chose an authentication
method the server doesn’t support. Choose Password from the
Authentication pop-up menu in the SMTP Server Options window
(see Figure 7); if that doesn’t work, try the other authentication
methods in the menu until you find one that does.

FIGURE 7

Click the Server Settings button at the bottom of the Account
Information tab of Mail’s Accounts preference pane to display this
dialog. When an SMTP server requires authentication, more often
than not Password is the right method—try that one first.
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• The SMTP server “smtp.domain.com” rejected the pass-
word for user “username”: This can mean either an incorrect
user name or an incorrect password. Go to the Account Informa-
tion tab of the Accounts preference pane, click the Server Settings
button, and reenter both User Name and Password, then try again.

• The sender address user@domain.com was rejected by
the server: Regardless of your authentication settings, some ser-
vers only accept email when the From address matches the User
Name. Make sure your email address matches the account from
which you’re sending email.

Purge SMTP Settings
Often when you edit SMTP settings, Mail adds a new server to its in-
ternal list rather than changing the existing entry. As a result, your
list of SMTP servers can become cluttered with invalid entries. If you
choose one of these accidentally, you’ll be unable to send email. To
clean up this list, follow these steps:

1. Make sure you have a record (preferably a written record) of the
correct SMTP settings for each of your accounts, then choose Edit
Server List from the pop-up menu at the bottom of the Account
Information tab of the Accounts preference pane.

2. Look for entries with nothing in the column labeled In Use by
Account. Select these and click Remove Server. Read the warning,
click Yes, then click Done.

3. In case of serious errors, you may wish to delete all the SMTP
servers and reenter the information from scratch. After doing so,
add them back one at a time, sending yourself a test message each
time to confirm that the settings are correct.

Mail’s SMTP server list now contains only valid entries.
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THE VIEWER WINDOW

Mail’s main window is called the Viewer window; this is where you
list, view, and search for messages. Although this window seems
straightforward, it has a few features that may not be obvious, but
that are important to understand in order to work effectively.

Put the Mailbox Drawer on the Left
This has bugged me since day one. Why is the drawer containing
Mail’s Mailbox list on the right side of the window? It’s on the left
in virtually every other email application, and that seems much more
natural to me. Although Mail’s interface obscures this fact, you can
move the drawer to the other side easily. First, close the drawer by
clicking the Mailboxes button in the toolbar. Then move your entire
window near the right edge of your screen. Now click the Mailboxes
button again to display the drawer—this time, on the left—and
reposition your window wherever you want it. Mail remembers this
setting even after you quit.

TIP You can open multiple Viewer windows if you wish, each with its
own customized list of messages and other settings. To open another
Viewer window, choose File > New Viewer Window.

Use (Or Hide) the Preview Pane
By default, Mail’s Viewer window displays a scrolling list of messages
in the top portion of the window, with the content of the selected
message in a pane (the Preview pane) at the bottom. This arrange-
ment saves screen real estate by keeping everything in a single win-
dow; it also enables you to read any message with just one click.

And yet I can think of at least three reasons you may not like the
Preview pane. First, if you have lots of messages in your In box, you
may prefer to devote as much of the window as possible to displaying
the list of messages. Second, you may want to avoid seeing the con-
tent of some messages (such as advertisements for objectionable Web
sites). But to delete a message, mark it as Junk Mail, or move it to
another folder, you must select it—and selecting it normally displays
its content in the Preview pane! And third, because the Preview pane
displays messages immediately, the mere act of selecting a message
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marks it as Read; you may wish to select a message (to move it, say)
but keep it marked as Unread until later.

One solution is to hide the Preview pane. To hide it, double-click the
horizontal bar that separates the message list from the Preview pane.
With the Preview pane hidden, you can display any message in its
own window by double-clicking it (or selecting it and pressing
Return), and simply selecting messages no longer marks them as
Read. If you later decide you want to see the Preview pane, double-
click the divider bar—which is now at the bottom edge of the Viewer
window—and Mail displays it again. (You can also, if you prefer, man-
ually drag the bar downward to hide the Preview pane and upward to
reveal it—but remember that it must be completely hidden to prevent
selected messages from being marked as Read.)

I should mention that there is another way to move messages—even
with the Preview pane visible—without displaying their contents or
marking them as Read. The trick is to move your pointer over the
message in the message list, press the mouse button, and then
without releasing the mouse button drag the message immediately
to another mailbox. Personally, I find this procedure cumbersome,
but some people swear by it.

TIP COUNTING MESSAGES

Mail displays the total number of messages in the current list on the
Status Bar at the top of the window, and if you use the Search box to
find specific messages, the Status Bar shows the number of matches.
But what if you manually select a bunch of messages and want to
know how many are in the selection? Here’s how: after selecting the
messages, just drag them slightly (as though you were going to move
them). A red badge appears next to the pointer showing the number
of messages selected.

Consolidate Message Lists
Ordinarily, the message list displays the contents of the selected
mailbox in the Mailbox list. (I discuss the message list in more detail
ahead under Mailbox Basics.) If you have multiple accounts and
select one of the “consolidated” mailboxes (In, Sent, and so on), the
message list displays the contents of all the sub-mailboxes; to display
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just one (say, a single account’s In box), click the triangle next to the
consolidated mailbox icon, then select the individual account name
from the list below.

Surprisingly, though, you can consolidate the display of any mail-
boxes. For example, if you want to see the contents of your In box,
Drafts box, and a personal folder all at one time, Command-click to
select all three in your Mailbox list, and the message list displays the
contents of all the selected mailboxes in a single list.

This hidden feature gets even more interesting in conjunction with
Mail’s Message Threading feature. If you consolidate the display of
multiple mailboxes and choose View > Organize by Thread, Mail sorts
messages by thread, even though they’re actually in different mail-
boxes. You might find this useful, for instance, to see a series of
messages you and a friend exchanged on some topic. If you select
your In box (or a mailbox where you’ve stored your friend’s replies)
along with the Sent mailbox, you can see messages you’ve sent and
received on each topic threaded together in chronological order.

Manage Incoming Message Formats
An incoming message may contain more than one copy of its text,
each in a different format. Ordinarily, Mail displays incoming mes-
sages in the format it deems best. If a message contains an HTML
version of the text, Mail displays that; second choice is rich text, if
present, and plain text is last. (For more about message formats, see
Formatting Outgoing Email, later.)

Because a given message can contain multiple copies of its content in
different formats, Mail provides a way to switch among them:

• When viewing a rich text or HTML message, you can switch to the
plain text version, if present, by choosing View > Message > Plain
Text Alternative (Command-Option-P).

• You can also use the commands View > Message > Previous
Alternative and Next Alternative (Command-[ and Command-],
respectively) to step through the versions.

Mail does not indicate which format(s) a message contains, or which
format you’re currently viewing. To find out, check the raw source of
the message (View > Message > Raw Source or Command-Option-U).
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TIP When an incoming message contains a URL, the URL usually ap-
pears blue and underlined; clicking the URL opens it in your default
Web browser. For Mail to make a URL clickable, though, it must be
able to figure out that a particular sequence of characters is a URL, a
process that is much more likely to succeed if the sender included the
complete URL (e.g., http://www.apple.com/ rather than just
apple.com).

You may sometimes, however, receive a message containing a fully
specified URL that is nevertheless not clickable. This happens if the
message is in HTML format (even though it may look like plain text)
and the person or automated system that sent it did not enclose the
URL in link tags (<a href="…">…</a>).

If this happens, choose View > Message > Plain Text Alternative
(Command-Option-P). If the HTML message included a plain text
version, that version of the text should contain clickable links. If not,
select the URL manually and choose Mail > Services > Open URL.

If you prefer plain text
To force Mail to display the plain text version of any new incoming
messages initially, you must turn on a hidden preference. First quit
Mail if it’s running. Then open Terminal (in
/Applications/Utilities) and enter:

defaults write com.apple.mail PreferPlainText -bool TRUE

Now quit Terminal and reopen Mail. Messages display a plain text
version, if one is present. As always, use the View > Message sub-
menu to view other formats.

http://www.apple.com/
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TIP THE MISSING REPLY WINDOW PROBLEM

Some Mail users have encountered the following odd problem: An
incoming message appears correctly (in the Preview pane or in its
own window). When you click Reply, however, the new window that
should contain your reply does not appear. If you quit and relaunch
Mail, the window does appear, but possibly without your signature or
quoted content from the original message. This bug affects incoming
messages in HTML format, particularly from certain versions of AOL.

The workaround is to force the message into plain text format before
replying. You can do this either by choosing View > Message > Plain
Text Alternative (to affect only the current message) or by following
the instructions just previously for changing Mail’s defaults using
Terminal (to affect all incoming messages).

If you prefer HTML without graphics
For incoming messages in HTML format, Mail provides an option to
disable display of embedded graphics. The main reason for this
preference is to foil “Web bugs”—images that, when downloaded and
viewed, signal the server that you’ve read the message. (For plain text
and rich text messages, you cannot turn off inline graphics display.)

To prevent Mail from showing graphics automatically in HTML mes-
sages, go to the Viewing preference pane and deselect the checkbox
labeled Display Images and Embedded Objects in HTML Messages.
While viewing an HTML message with graphics off, to see the graph-
ics, click the Load Images button near the top of the message window.
(You can hide the Preview pane entirely to avoid seeing messages
before filing or deleting them; see Use (or Hide) the Preview Pane.)

TIP THE BACKWARD PRINTING PROBLEM

Occasionally you may print a message and find that the text comes
out backward (and upside-down). This is a bug, but there are at least
two ways you can work around it:

• Choose Format > Style > Bigger (or Smaller); then try printing
again.

• Redirect the message to yourself (choose Message > Redirect,
enter your own email address, and click Send). Then print the new
copy of the message when it arrives.
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INCOMING ATTACHMENTS

When you check your email, Mail downloads all messages, usually
including their attachments. This section explains how to open
attached files and how to adjust the way Mail downloads and saves
attachments.

Opening Attached Files
When an incoming message contains one or more attachments, you
can open or save them in various ways:

• If the attachment appears as an icon in the body of the message,
you can single-click it (as though it were a hyperlink) to open it in
the default application for that file type. When you do this, how-
ever, the file will be read-only unless you save a copy from within
the application. (If the file is compressed, single-clicking it causes
StuffIt Expander to launch, and StuffIt Expander will prompt you
for a location to store the decompressed file.)

• In the case of an attached graphics file that shows as an icon,
Control-click (or right-click) its icon and choose View in Place
from the contextual menu. (The View in Place command is
dimmed if the graphic is compressed.)

• You can Control-click (or right-click) an attachment, whether in
icon or inline graphical form, and choose a command from the
contextual menu, as shown in Figure 8: Open Attachment (in the
default application); Open With (any compatible application); Save
Attachment (to a location of your choice); or Save to Downloads
Folder (which by default is your Desktop folder).

FIGURE 8 Control-click (or right-
click) an attachment in
an email message to
display a contextual
menu with options for
using the attachment.
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TIP To change your default Downloads folder, which is also used by
Safari, open Safari, choose Safari > Preferences, click the General tab,
and choose a new location from the Save Downloaded Files To pop-
up menu.

• Click the Save All button in the header of the message and browse
to the folder where you want to store the files.

• Drag and drop the attachments from the Mail window to your
Desktop or folder. But note: unlike other methods for saving
attachments, when you drag and drop, Mail makes attachments
read-only; you will be unable to modify one unless you select it in
the Finder, choose File > Get Info, and choose Read & Write from
the first pop-up menu under Ownership & Permissions.

TIP Tired of manually changing permissions for attachments you’ve
dragged to the Desktop? Try this idea from MacOSXHints:
http://www.macosxhints.com/article.php?story=20031212215917675.
It uses an AppleScript folder action to automatically set every new file
placed on the Desktop to read/write permission.

After you copy an attachment to your disk, you may wish to remove
it from your message (that is, unless you plan to delete the message
anyway). Doing so can save disk space; this is especially helpful for
users with IMAP, .Mac, and Exchange accounts. To remove attach-
ments, select one or more messages and choose Message > Remove
Attachments. Be aware, though, that some messages are formatted
in such a way that Mail cannot remove their attachments.

NOTE Mail leaves attachments inside the message file itself (part of the
.mbox or .imapbox mailbox files located in ~/Library/Mail/
account-name). Thus, if you open an attachment from within a
message, the file you open is stored deep in the catacombs of your
Mail folder. If, on the other hand, you save the attachment (using the
File > Save Attachments command, say, or by drag-and-drop), you
copy the attachment. The original stays inside the message until you
delete the message or manually remove the attachment. (Mail doesn’t
exactly remove attachments; instead it duplicates the message, omit-
ting attachments, and then it deletes the entire original message.)

http://www.macosxhints.com/article.php?story=20031212215917675
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Downloading (or Not) Attachments
For POP accounts, you can choose not to download messages larger
than a specified size (including attachment size), but you can’t down-
load the text of a message without its attachments. To set the message
size threshold, go to the Advanced tab of Accounts Preferences for
your POP account and enter a value in the field, Prompt Me to Skip
Messages over __ KB.

For IMAP, .Mac, and Exchange accounts, you can choose not
to download attachments with their messages: Go to Accounts
Preferences, click the Advanced tab, and—from the pop-up menu
labeled Keep Copies of Messages for Offline Viewing—choose All
Messages, but Omit Attachments. Don’t be misled by the word
“keep”; with this setting selected, Mail does not download the
attachments at all unless you explicitly ask it to (see the note just
ahead). Remember, however, that the attachments remain on the
server with the rest of the message—a consideration if your server
imposes storage limits.

NOTE If you choose not to omit attachments when retrieving email from
an IMAP, .Mac, or Exchange account, icons representing the attach-
ments still appear in the message window, and you can download
them manually. When you try to save or drag an attachment that has
not been downloaded (as indicated by a gray-colored file name), Mail
prompts you to download it first. Once downloaded, the attachment
remains cached locally until you remove it manually or rebuild the
mailbox that contains the message.

Attachments from Entourage 2001 Users
Entourage 2001 (which is still widely used, even though it was rep-
laced by version X and, more recently, version 2004) contains a bug
in the way attachments are encoded. If a message is in HTML format,
sometimes—though not always—attachments are not visible when the
message is viewed in Mail. Instead, upon opening the message, a Mail
user sees the notice: “This message cannot be displayed because of
the way it is formatted. Ask the sender to send it again using a differ-
ent format or email program.”
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The sender of the message can work around the problem by using
Plain Text format or, better yet, upgrading Entourage to a newer
version. However, if you receive such a message you can save and
view the attachment without imposing on the sender. Follow these
steps:

1. With the message selected (or open), choose File > Save As.

2. In the dialog that appears, give the message a name (any name),
choose a location (such as your Desktop), and—very
important—choose Raw Source from the pop-up Format menu at
the bottom.

3. Drop the text file that has just been created onto StuffIt Expander
(in /Applications/Utilities).

StuffIt Expander produces a folder containing several files, among
which will be any attachments to the message.

4. You can now work with the attached files. However, note that if an
attachment was compressed, you must drop the compressed file
onto StuffIt Expander separately to extract the original file.
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ADDRESSING EMAIL

When addressing an email message, you can, of course, just type
email addresses into the provided address fields (To and Cc). How-
ever, you may wish to easily enter email addresses that you do not
have memorized and you may wish to display the hidden address
fields, Bcc and Reply-To. In this section, I explain how to handle each
of these addressing scenarios, and I discuss sending email to groups.

NOTE If you have multiple accounts, Mail’s New Message window displays
a pop-up Account menu just above the message body. When you
choose an account from this list, Mail sets both the From address and
the SMTP server to match the settings for that account.

Address Book
Mail relies on a separate application to store frequently used email
addresses. Address Book is, in theory, a great idea: a single, system-
wide contact database that any application can access. Most programs
continue to use their own address lists, however, and even the integ-
ration between Address Book and Mail leaves a lot to be desired. In
addition, some quirks in the way Mail handles addresses have caused
confusion and aggravation for many a Mail user.

Mail assumes you’ve already entered all your important email ad-
dresses in Address Book. If you have, you can access the addresses
through the Address Panel or by using automatic addressing. (If you
haven’t already filled in your Address Book with your most frequently
used email addresses, consider doing so—it will make your life a lot
easier.)

NOTE If you enter an address in the To field of an outgoing message and
then realize you also want to have it in your Address Book, you must
add it there manually. In contrast, when you receive email, you can
add the sender’s name and address to Address Book by choosing
Message > Add Sender to Address Book—but no analogous command
exists for recipients of outgoing email.
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The Address Panel
One way to access stored addresses is to display a floating window
with the contents of your Address Book. To do this, choose Window >
Address Panel (Command-Option-A) or click the Address button on
the toolbar of the New Message window. In the Address Panel, you
can first select an address or group (or Command-click to select mul-
tiple addresses), then to address your message, click the To: or Cc:
button or drag the selected items to an address field. Curiously, there
is no Bcc: button; to send blind carbon copies to the selected contacts,
you must manually display the Bcc field (see Hidden Address Fields,
just ahead) and then use drag-and-drop to enter the addresses there.

You can even search for a contact by name or address using the handy
search field. However, the Address Panel is not editable. To add or
change contact information, you must launch Address Book. (Mail
has no menu command or keyboard shortcut to open Address Book;
you must do this manually.) If you happen to have Address Book
open anyway, you can drag and drop addresses from its contact list
into Mail’s address fields just as you can with the Address Panel.

NOTE The Address Panel contains only the contacts in your Address Book,
not the records from any LDAP servers you may be using. See LDAP
Servers, ahead, for more information.

Automatic Address Completion
You can use your address list to address a message, without having to
open a separate window and search for a contact, by typing part of the
name into the To field. Type the first few letters of a first name—or
last name or email address, for that matter—and Mail automatically
displays all entries from your Address Book, Previous Recipients list
(see Handle Previous Recipients), and defined LDAP servers (see
LDAP Servers, just ahead) that match. Now, use the Up and Down
arrow keys to select the one you want, press Return, and you’re done.

TIP When using automatic completion to enter more than one email
address in the same field, use commas to separate the addresses—but
be aware that the commas are not visible in address fields when auto-
matic address completion is enabled.
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After typing a few letters of a name or address, you can expect a delay
lasting up to several seconds as Mail searches for matches in its vari-
ous lists. This delay can be irritating if you have many addresses to
enter. Automatic addressing has a few other problems as well, which
I detail in the sidebar on the next page, “Problems and Quirks with
Automatic Addressing.” Automatic address completion is on by de-
fault; to turn it off, go to the Composing preference pane and deselect
Automatically Complete Addresses.

NOTE Addresses are considered “objects,” meaning that each entry in an
address field appears inside a blue oval, which you can select, drag
and drop, or delete with a single click. (Only contacts in your Address
Book or Previous Recipients list appear as objects, not addresses you
enter manually.) This makes it easier to read long lists of addressees,
and clicking an address displays a pop-up menu from which you can
choose, among other things, an alternate address for the same
contact.

Objects can lead to some unexpected behavior. For example, if you
highlight an address in the automatic completion list and type a
comma (to indicate that you want to add another address), Mail
enters the address you highlighted but does not display the comma in
the address field. You can temporarily turn off the object-like display
for a single address by clicking it and choosing Edit Address from the
pop-up menu. But you cannot turn off object display altogether. Even
with automatic address completion disabled, addresses you’ve typed
manually appear as objects when you leave the address field if those
addresses are in your Address Book.
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SIDEBAR PROBLEMS AND QUIRKS WITH AUTOMATIC ADDRESSING

I’ve encountered several problems with Automatic Addressing, which
I explain here so you can learn how to best cope with them.

• The order in which matches appear when you use Automatic
Addressing is somewhat unpredictable. Usually, matches from the
Previous Recipients list and Address Book appear before matches
from LDAP servers, and matches of an email address appear be-
fore matches of a name. But this doesn’t always mean you can
easily get the address you want. Suppose I want to enter MJ, my
wife’s initials, to send her a message. Since those letters are part
of her email address, it appears as one of the options, though not
necessarily the first one—my Address Book happens to have six
addresses beginning with “mj.” Unless the address I want is the
only match (or at the top of the list), I have to pay attention to the
choices and scroll until I find the right one—extra steps that make
the process harder rather than easier. Mail has no “nickname”
feature to specify custom shortcuts for frequently used addresses.

• To further complicate addressing, Mail by default displays just the
addressees’ names in the address fields after you enter them—not
their addresses. So if you have a contact with multiple email ad-
dresses, you can easily enter the wrong one without realizing it.
You can toggle the setting to show both the name and address—the
menu command to show addresses is View > Addresses > Show
Name and Address, but the opposite of this—show name only—is
View > Addresses > Smart Addresses.

• As if to acknowledge the tendency of automatic address comple-
tion to steer you wrong, Mail includes a preference to highlight
addresses outside domain(s) you specify. That way, if you mistak-
enly choose John Smith your neighbor instead of John Smith your
CEO, you get some warning before sending that confidential finan-
cial information. Turn on this feature in the Composing preference
pane by selecting Mark Addresses Not in This Domain. Enter the
“safe” domain in the field provided; to use more than one, separate
them with commas—for example apple.com, mac.com,
xyz.com. The next time you address a message to anyone outside
the specified domains, that person’s address will appear in red.
Color is the only indication of an unsafe domain—if you’re color
blind or using a grayscale display, you’re out of luck.
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LDAP Servers
In addition to consulting your Address Book and Previous Recipients
list, Mail can also find email addresses stored on an LDAP (Light-
weight Directory Access Protocol) server. If you use your Mac at home
or in a small business setting, you probably have no use for LDAP.
But if you are part of a large corporation or university, LDAP can save
you untold time and aggravation.

In a nutshell, an LDAP server is a centrally maintained address book.
So let’s say you’re a student at a university where 40,000 students
each have a unique email address. By configuring Mail to use the
university’s LDAP server, you effectively add all 40,000 addresses to
your local address list instantly. Better yet, the list is dynamic, chang-
ing automatically as accounts are added, deleted, or modified.

You can add LDAP servers either within Mail (go to the Composing
preference pane and click the Configure LDAP button) or in Address
Book (choose Address Book > Preferences and click the LDAP button
on the toolbar)—the two applications share the same list. However,
only your system administrator can tell you what to enter in the
Server and Search Base fields.

The LDAP server(s) that you have configured appear in Address Book
under the Directories group. Selecting a server does not cause all the
entries on that server to display, but as soon as you type in the Search
field (even if only a letter or two), you see all entries that include the
string you entered. Matches from your LDAP servers also appear in
the automatic address completion list when you type in an address
field. However, LDAP servers do not appear in Mail’s Address Panel.

Hidden Address Fields
Normally when you send someone a message, you put her address in
the To field. You may also choose to put one or more addresses in the
Cc (Carbon copy) field, which simply indicates to the recipient that
the message is for informational purposes. Two additional addressing
options are available: Bcc and Reply-To.

Bcc
A third address field, Bcc (Blind carbon copy) functions like Cc except
that none of the recipients (regardless of which field contained their
address) will see the Bcc addresses. For example, if you write a mes-
sage recommending a friend for a job, you might include the friend as
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a Bcc recipient, so that she can read the nice things you wrote about
her without the prospective employer knowing that she also received
the message. The Bcc field is off by default; to display it, choose View
> Bcc Header. This setting applies to all new messages you compose.

WARNING! Use Bcc only when you’re certain the person you’re copying under-
stands how it works. If your Bcc recipient replies to the message
using Reply To All, the original recipient will receive the reply—and
will know who you sent the copy to!

Reply-To
Yet another hidden address field, Reply-To, enables you to specify
that replies to this message should go to a different address than the
one you sent it from (see Figure 9).

FIGURE 9

You can add a Bcc or Reply To field (or both) to the headers of all
new outgoing messages using commands on the View menu.

For example, if you send a message from your personal account at
home but want the recipient’s reply to go to your work account, put
your work email address in the Reply-To field. To display the Reply-
To field, choose View > Reply-To Header. (As with Bcc, this setting
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applies to all new messages.) Be aware, however, that not all email
clients honor the Reply-To setting, and the recipient can also choose
to override that address manually.

TIP Although you can easily set up Mail to display Reply-To and Bcc
fields for every new message, those fields are blank, requiring you to
enter the appropriate addresses for each message. If instead you want
to specify a default Reply-To, Bcc, or custom header to be included in
all outgoing messages, the easiest way to do so is to download and
run a tiny AppleScript application, made available for free by
“Cricket,” a member of Apple’s Mail development team.
http://homepage.mac.com/cricket/.cv/cricket/Public/Applescripts/
Add%20Headers%20to%20Outgoing%20Email-binhex.hqx

Note that the addresses you add using this application do not appear
in Mail’s Reply-To or Bcc field, but the headers are still inserted in
the outgoing messages as they’re sent.

Sending Messages to Groups
If you want to send email to a given set of people repeatedly—say, all
the members of a committee, your Monday night quilting club, or
your company’s sales force—you can define a group in Address Book
to simplify this process. To make a group, click the + (plus) button at
the bottom of the Group list in Address Book and enter a name for
your new group. Then drag contact names from the All group, an
LDAP directory, or another group to the new group icon.

To send a message to all the people in that group, drag the group
name from the Address Panel into an address field, or type the first
few letters of the group’s name and let automatic address completion
do the rest for you.

But what if contacts in a group have multiple email addresses? By
default, Mail sends messages to whichever address appears first in
a given contact’s Address Book record. To change this, open Address
Book and choose Edit > Edit Distribution List. Select a group name to
display its members. If a member has more than one email address,
the one currently used by Mail appears in bold, while the others ap-
pear in light gray. Click one of the gray addresses to select it for use

http://homepage.mac.com/cricket/.cv/cricket/Public/Applescripts/Add%20Headers%20to%20Outgoing%20Email-binhex.hqx
http://homepage.mac.com/cricket/.cv/cricket/Public/Applescripts/Add%20Headers%20to%20Outgoing%20Email-binhex.hqx
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when sending email to this group. Then click OK. (The only way to
create a group that includes two or more different addresses for one
person is to create a separate contact for each new address.)

Prior to Panther, if you put a group name in the To or Cc field of an
outgoing message, Mail automatically expanded it, listing each group
member’s address in the field. (So each recipient saw all the other
addresses—a faux pas.) Mail 1.3 “corrected” this problem, but created
a new one. Assuming default settings, only the group name appears
in an address field. When each recipient gets the message, however,
it will appear to have been addressed to group-name@outgoing-
server-name (for example, classmates@mac.com). Such an address
is almost certainly invalid and it may lead the recipients to assume
incorrectly that they can use it to reply to all the other recipients.
To avoid this problem, do one of the following:

• To be sure all the recipients do see each other’s addresses, click
the group name in the address field and choose Expand Group
from the pop-up menu. (To turn on automatic group expansion for
all new messages—reverting to Mail’s former behavior—go to the
Composing preference pane and select the checkbox labeled When
Sending to a Group, Show All Member Addresses.)

• To ensure that recipients don’t see each other’s addresses and also
don’t see a bogus “To” address, enter the group name in the Bcc
field instead of To or Cc. The “To” field in the message each recipi-
ent gets will say “undisclosed-recipients: ;” (even if the group is
expanded into individual addresses). If you don’t see a Bcc field,
choose View > Bcc Header (Command-Option-B).

NETIQUETTE When sending email to a group of people, use Bcc (or turn off auto-
matic group expansion) to keep addresses private and minimize
scrolling for the recipients.
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FORMATTING OUTGOING EMAIL

An important aspect of message preparation is choosing a message
format—although you can select a format individually for each out-
going message, you will probably want to pick one to use most of the
time and stick with it. Your built-in choices are plain text and rich
text, though it is also possible to send HTML-formatted messages
with a bit of effort.

• Plain text: Plain text is ideal when readability is paramount, or
when you aren’t sure what kind of software the recipient is using.

• Rich text: Rich text is appropriate when you want to provide
basic formatting and are certain the recipient’s email client can
show styled text. (See Table 2, on the next page, for the capabili-
ties of popular email clients.)

• HTML: HTML may be a good choice if you need to include nicely
formatted tables, bulleted or numbered lists, or compact clickable
links—and you’re sure your recipient will be able to view them.
(See HTML Messages, just ahead.)

NETIQUETTE USE PLAIN TEXT WHENEVER POSSIBLE

Tempted to use rich text or HTML? In many cases, you can convey
your message just as well using plain text. Consider whether your
aesthetic desires outweigh the simplicity and universality of plain
text. To this day, every time I get a message written entirely in, say,
green, 10-point Copperplate Oblique—and believe me, it happens—I
just cringe. However nice the sender may have felt the text looked, it
takes so much effort to read it that I wonder if I should bother. I
know what fonts, styles, and sizes are easiest to read on my comput-
er, and I dislike receiving messages that override those choices with-
out my consent.

As you might have guessed, I strongly believe that plain text is the
path to world peace!

Setting Your Default
To choose a new default format for outgoing messages, go to the
Composing preference pane and choose Plain Text or Rich Text from
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the Format pop-up menu. To toggle the format of the current
message, choose Format > Make Rich Text (or Make Plain Text).

Table 2: Capabilities of Popular Email Clients

Application
Sends
HTML

Displays
HTML

Sends
Rich Text

Displays
Rich Text

Displays Inline
Graphics

AOL Yes Yes Yes Yes Yes4

Entourage1 Yes Yes No Yes Yes

Eudora Yes Yes No Yes Yes

GNUMail1 No Yes No No Yes

GyazMail1 No Yes No No5 Yes

Mail1 No Yes Yes Yes Yes

Mailsmith1 No No No No No

Mozilla Yes Yes No Yes Yes

Mulberry Limited Limited Yes Yes No

Netscape Yes Yes No Yes Yes

Outlook2 Yes Yes No6 Yes No7

Outlook Express3 Yes Yes No Yes Yes

Pegasus Mail2 Yes Yes No Yes No

PowerMail1 No Yes No Yes No

Thunderbird Yes Yes No Yes Yes

1Mac only 2Windows only 3Windows and Mac OS 9

4In current version, user must select inline display manually for each image.

5Converts Rich Text into HTML, which can then be viewed in a browser.

6What Outlook calls “Rich Text” is Rich Text Format (RTF), not “text/enriched.”

7Only (and optionally) for messages sent in HTML format.
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NETIQUETTE MAKE A GOOD IMPRESSION

Email is an informal medium, but that’s no excuse for sloppiness.
Show your recipients that you take them seriously by using proper
capitalization and punctuation, checking your spelling, and writing
in complete sentences. To check your spelling for an entire message,
choose Edit > Spelling > Spelling; or choose Edit > Spelling > Check
Spelling As You Type for an interactive spelling checker.

HTML Messages
For reasons only Apple knows, Mail can’t compose messages in
HTML format. Although I personally prefer plain text any day, Mail’s
inability to compose HTML email baffles me because almost every
other modern email client can do it, whereas only a few still use rich
text for outgoing messages (see Table 2, on the previous page).

NOTE Although Mail can display HTML messages without difficulty, if you
use Mail to forward (or redirect) an HTML message you’ve received,
the HTML will be broken and the recipient will get unreadable gib-
berish. If you need to forward an HTML-formatted message to some-
one else, your best bet is to use a different email client to do so.

You could work around this problem using the MailPictures plug-in
(see instructions just ahead). To do this, open the HTML message,
choose View > Message > Raw Source, select only the HTML portion
of the source, and paste that into a new message window with Mail-
Pictures activated (and Message is Raw HTML selected). But that’s
a lot of work, and there’s still no guarantee the message will look
exactly like it did when you received it.

Steve Jobs announced that the version of Mail to be included with
Mac OS X 10.4 Tiger (when it ships in the first half of 2005) will, at
last, include HTML composition capabilities. In the meantime, if you
want to send HTML-formatted email, you have several options. You
can coax Mail into sending email in HTML format if you install the
free MailPictures plug-in (see Appendix A: Software Sources).
Although primarily designed to permit inclusion of your photo in
outgoing messages, MailPictures has an obscure option that enables
HTML format in the New Message window. There’s just one catch:
you must hand-code the HTML (or paste it from another program);
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MailPictures provides no graphical user interface for composing
HTML. To use MailPictures for HTML messages:

1. Download and install MailPictures.

2. Go to the MailPictures preference pane. (If the MailPictures button
is not visible on the toolbar, click the » icon on the right side of the
toolbar and choose MailPictures from the pop-up menu.)

3. Make sure the Enable Mail Pictures checkbox at the top of the
window is selected. Then click the Advanced tab and select Show
Options in Compose Window.

4. When you compose a new message, extra controls appear below
the address fields. Select Message Is Raw HTML (see Figure 10).

FIGURE 10

The MailPictures plug-in gives you the option of sending HTML-
formatted messages: select the Message Is Raw HTML checkbox;
then type or paste HTML code into the message body.
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5. Type the HTML code into the body of the message or click Import
to choose an HTML file you created in another application.

When you send your message, Mail delivers it in HTML format. Note,
however, that such messages do not include a plain-text alternative,
and will be unreadable in some email clients.

TIP If you plan to send a lot of HTML messages using MailPictures, con-
sider composing the messages using a graphical authoring tool such
as Adobe GoLive or Macromedia Dreamweaver, and then pasting the
HTML code it generates into Mail.

NOTE Andreas Amann, who created the outstanding Mail Scripts package
(see Appendix A: Software Sources), devised an AppleScript-based
strategy for sending HTML-formatted messages with Mail. See his
solution at http://macintouch.com/mail.app07.html#apr08.

If coding your own HTML sounds like a bit too much fun, many email
applications offer a proper graphical user interface for composing
HTML email. In my opinion the best choices are Mozilla, Netscape,
and Thunderbird, all of which share the same basic email engine.
Besides offering HTML formatting, they enable you to choose, for
each recipient, whether the message should include HTML only, plain
text only, or both. And you can’t beat the price—free. (Eudora and
Entourage also offer the option of HTML format.)

If you’re trying to send a newsletter or other high-volume HTML
message, you can find applications that give you mail merge-like
substitution features. Examples are Mail Magic, MaxBulk Mailer,
and Newsletter; see Appendix A: Software Sources for details. It goes
without saying that you should never, ever use such applications to
send unsolicited commercial email (otherwise known as spam).

http://macintouch.com/mail.app07.html#apr08
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QUOTED TEXT

You may find that the quoted text in your replies and forwarded
messages has ugly or excessive line breaks. Or, you may find that the
left margin has a ridiculous number of quote marks. This section
explains how to fix these problems.

According to Internet convention, quoted text is marked with a >
character:

> This is a sentence from an earlier message that I’m quoting
> in the current message.

In Mail, however, a vertical bar appears in place of the > to indicate
quoted text. (If you reply to a reply or forward a message that was
forwarded to you, an extra bar appears for each iteration.) The bar is
purely cosmetic; Mail maintains the > characters behind the scenes,
and that’s what your recipients will see unless they use Mail or
another email client that opts for bars. (By the way, if you dislike the
bars, sorry—Mail offers no way to turn them off.)

The rationale behind the bars is that they are flexible with respect to
line wrap. Some email clients force text to break to the next line at a
certain number of characters per line (usually 60–80), while others—
including Mail—don’t. So the idea is that you can resize your window
to any width, and text in your paragraphs dynamically rewraps to a
new line width, all the while showing the proper level of quoting,
without > characters mixing into the text.

NOTE Mail displays bars instead of > characters at the beginning of each
line followed by a space. A few email clients omit spaces when
quoting text, and in those cases Mail displays the > signs just as in
the original.

Unfortunately, in practice, automatic rewrapping of quoted text
works only if your correspondents use Mail or another email client
that treats quoted material similarly. If a sender uses an email client
that inserts hard line breaks, Mail leaves them just the way they were.
As a result, when you forward or reply to such messages—especially if
you include only a portion of the quoted text—you’re left with ugly,
ragged paragraphs that are difficult to read.
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Fix Unwanted Line Breaks
Some email clients thoughtfully include a command to rewrap para-
graphs that have hard line breaks; such a command works by replac-
ing return (line break) characters with spaces. Mail has no such
command, and manually deleting return characters is tedious at best.

Fortunately, a free solution is available. Word Service, from Devon
Technologies, provides several text-formatting commands for any
application that supports the Services menu. (See Appendix A:
Software Sources.) One of these commands, Reformat, fixes ragged
paragraphs. After installing the software, select a range of text in an
outgoing Mail message and press Command-&. Poof! Rewrapped
paragraphs. This works even if the text was badly quoted—though you
may have to adjust the quote level of the entire paragraph afterward
(read later on this page to find out how to adjust the quote level).

NETIQUETTE QUOTE ONLY RELEVANT PORTIONS OF A MESSAGE IN A REPLY

When answering a question or commenting on a statement, include
just enough of the original text to provide context for your reply. And
for best readability, put your reply after the quote. For example:

which brings us to the present. So having read my life’s story,
where do you think I should go on vacation?

Hawaii. But watch for falling coconuts. You don’t want another
concussion.

Some email clients, notably Microsoft Outlook, put replies above the
quoted text by default. An email signature I’ve seen nicely expresses
the problem with this approach:

A: Because it reverses the natural flow of conversation.
Q: Why is top-quoting frowned upon?

Manage Quote Characters in the Left Margin
To change the level of quoting for a portion of text (especially useful
when sending a message that has received a series of replies), choose
Format > Quote Level > Decrease (or Increase, as the case may be).
And if you want to paste text into your email message with quote bars
already inserted, choose Edit > Paste as Quotation (or press Shift-
Command-V) instead of pasting normally.
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CLICKABLE LINKS

Countless Mail users have observed that when incoming messages
contain URLs, they usually appear as blue, underlined links; clicking
them opens the page in a Web browser. Yet, typing or pasting URLs
into Mail does not appear to create clickable links (as occurs automat-
ically in some other email clients) and no command seems to make
this possible. If you want to send someone a link she can click, how
do you do it?

For plain text and rich text messages, making links clickable is a
function of the email client on the receiving end, not the format of the
message or the application used to send it. Mail does this on the fly
for incoming messages; so do most other email clients. Mail refrains
from making links appear to be clickable as you type them because it
cannot guarantee the recipients will be able to click them; to suggest
they will be would be misleading. But have faith: as long as the recip-
ient uses a modern email client, the link will indeed be clickable on
the other end. (To test this, send yourself a message with a URL in it.)

NOTE If your recipient uses an email client that ignores Mail’s flowed text
and inserts hard line breaks, any URLs longer than one line will not
be clickable. (The same is true of some Web-based email systems.)
One way to work around this problem is to create a special, short
redirect URL using the free TinyURL service (http://tinyurl.com/).

When typing a URL, be sure to include the scheme (http:, https:,
mailto:, or whatever). Without a scheme, the recipient’s email
client must guess whether it is really a URL. If the address begins
with www and ends with .com, chances are the client will consider it
a URL—but many URLs have a different format.

NETIQUETTE If you want to be especially kind to your recipients, enclose all URLs
in angle brackets, like this: <http://itotd.com/> or this:
<mailto:jwk@mac.com>. Doing so gives email clients an addition-
al hint as to where URLs start and end; this can be helpful if a URL
breaks across lines or if it is followed by punctuation, which the client
may incorrectly interpret as being part of the URL.

http://tinyurl.com/
http://itotd.com/
mailto:jwk@mac.com
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One thing you can’t do with Mail is make the text of the link different
from the underlying URL—for instance, you can’t have the text
“Apple” appear as a link to http://www.apple.com/. Doing this re-
quires the use of HTML format, which Mail does not support for
outgoing messages. (Though a few third-party add-ons do make it
possible to send HTML messages through Mail; see HTML Messages,
a few pages earlier, for more information.)

http://www.apple.com/
http://www.apple.com/


Page 69

OUTGOING ATTACHMENTS

You can make sure the vast majority of your attachments arrive intact
for the vast majority of your recipients by following a few guidelines
and learning more about how to send graphics as attachments.

Guidelines
Follow these guidelines for successfully sending attachments:

• Always include file extensions: Extensions never hurt, and
they often help (even when your recipient is a Mac user). To make
sure an individual file has an extension, select it in the Finder,
choose File > Get Info, and look in the Name & Extension section.
As far as Mail is concerned, it doesn’t matter if a particular file has
Hide Extension checked; as long as the extension exists, it comes
through on the recipient’s end. To save yourself the bother of
checking each file (at the expense of slightly less beautiful file
names), choose Finder > Preferences, click the Advanced button in
the toolbar, and select the Show All File Extensions checkbox. That
way you’ll always know at a glance whether a file has an extension.

NETIQUETTE NEVER ATTACH WHAT YOU CAN TYPE OR PASTE.
I once worked for a company where a lot of the senior management
(and, more importantly, their secretaries) still thought that internal
communication revolved around printed memos. I often received
email messages whose entire content was: “See enclosed memo.” So I
dutifully opened the attached documents in Word, where I invariably
found a paragraph or two of text in the company’s standard memo
template that could just as easily have been typed (or pasted) directly
into the email. This backward approach to communication annoyed
me mightily, because the senders’ failure to use email properly forced
everyone else to jump through hoops to read a simple message.

The moral? Use attachments only when they add something you can’t
convey in the body of a message. If you must attach a document from
a word processor, consider also copying the text into the body of the
message. This will enable your recipient to scan the content quickly
and easily, without having to open the attachment right away.

• Always use Windows-friendly attachments: Sending attach-
ments in “Windows friendly” format usually makes them friendlier
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for Macs too. (See the sidebar just ahead, Behind the Scenes with
Windows-Friendly Attachments.) To tell Mail to use Windows-
friendly encoding for all new messages, choose Edit > Attachments
> Always Send Windows Friendly Attachments. (Although this
command appears on a menu, it’s saved as a preference.) Oddly,
the command is disabled when you compose a new message.

You can also toggle Windows friendliness for individual messages:
When you attach a file using the Attach button on the toolbar or by
choosing File > Attach File (Command-Shift-A), notice the check-
box at the bottom, Send Windows Friendly Attachments (see
Figure 11). If it’s selected, all the attachments for this particular
message are sent in Windows-friendly format. Unfortunately, Mail
offers no convenient way to toggle Windows friendliness for
attachments added to your message by drag-and-drop or copy-
and-paste.

FIGURE 11

When you attach a file using the Attach File command (or the
Attach button on the toolbar), a file selection dialog like this one
appears. If the checkbox Send Windows Friendly Attachments at
the bottom is checked, all the files attached to this message will be
stripped of their resource forks—usually a good thing.
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• When a problem comes along, you must zip it: If file exten-
sions and Windows friendliness still result in attachments the
recipient can’t read, try compressing them (the files, not the
recipients). Zipping covers a multitude of sins by wrapping up one
or more files—including resource forks, if any—in a compact,
cross-platform-compatible package. Under Panther, you can zip a
file or folder in the Finder by selecting it and choosing File >
Create Archive of filename.

SIDEBAR BEHIND THE SCENES WITH WINDOWS-FRIENDLY ATTACHMENTS

The Windows Friendly Attachments feature has nothing to do with
extensions and does not add them for you. So, what does it do?

By default, Mail assumes your recipient is also a Mac user and there-
fore includes the resource forks (if any) of attached files. Normally a
Mac user sees such attachments as a single file, whereas a Windows
user sees two individual files—one containing the data fork of the file
and the other containing the resource fork.

When you choose “Windows Friendly” attachments, Mail strips the
resource fork so that Windows users receive just one file, not two
(one of which would be unusable anyway). In most cases—at least for
files created with modern applications—all the crucial parts of files
are in the data fork, so as long as the filename has the correct exten-
sion, Windows users can open it.

The term “Windows Friendly” seems to imply that using this option
makes your attachments “Mac Unfriendly.” Mail’s documentation
reinforces this worry by stating that Mac users may be unable to open
files correctly if the Windows Friendly option is used. But in practice,
just the opposite is frequently true. The Mac version of Eudora, for
example, sometimes cannot decode perfectly ordinary Mac files, such
as Word documents, if they were sent without using the Windows
Friendly setting. In other words, a wiser design would have been to
make “Windows Friendly” the default behavior, with an option to
make attachments “Mac Friendly” on those rare occasions when you
truly must.
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NETIQUETTE AVOID ATTACHMENTS IF POSSIBLE

Even if you get the filename and encoding right and compress the
files, attachments can still cause problems:

• Attachments sometimes take a long time to download—especially
for users with dial-up connections.

• Many ISPs also place strict limits on users’ mailbox sizes.

• Because of the proliferation of malicious files sent as email attach-
ments, many ISPs strip some (or even all) attachments from email
messages automatically as a security measure.

If you must send someone a file (especially a large one), check with
the recipient first. Alternatively, place the file on your iDisk or an FTP
or Web server and simply send a URL. Or send the file via iChat for a
direct, real-time file transfer.

Sending Graphical Attachments
When you attach a graphical image to your message, the recipient
sees the image inline (that is, in the body of the message) if her email
client supports inline display (see Table 2, earlier in “Formatting
Outgoing Email”). If it does not support inline display (or the recipi-
ent has turned off the inline display option), the file appears as an
attachment that must be opened in a separate program.

On the one hand, an inline image is easier for the recipient to see,
because all she has to do is look at it. On the other hand, inline images
can be frustrating to scroll through.

If you do not wish to send a graphical image inline, you must com-
press the file before attaching it—Mail, unfortunately, lacks a built-in
compression option. Under Panther, the easiest way to compress a
file (in Windows-friendly Zip format) is to select the file in the Finder
and choose File > Create Archive of filename.

NOTE When you compose a new message, Mail always shows attachments
in the body of your message. You can manually drag them somewhere
else, but many email clients display all attachments in a separate list,
regardless of where you place them in the message body.
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If you paste an image into a message or drag and drop an image from
another window (say, a Web browser), Mail converts the raw image
data to an attachment in TIFF format. On the other hand, if you drag
and drop the icon of an image file (or use the Attach button to locate
the file using the file browser), Mail leaves the attached image in its
original format. This difference is significant, because although most
email clients can display JPEG images just fine, support for TIFF—
especially in non-Mac email clients—is less common. If possible, I
suggest attaching image files as opposed to pasting or dragging in raw
image data.
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MANAGE MAILBOXES

Mail becomes easier to use once you understand the basics (and a few
oddities) of the way Mail organizes its mailboxes, what to do if more
than one person wants to use Mail on the same computer, and how to
respond to typical mailbox problems.

Mailbox Basics
Each account in Mail automatically has several mailboxes—Mail’s
term for the folders that organize your messages—including In, Out,
Drafts, Sent, Junk, and (optionally) Trash. You can also add your own
personal mailboxes. The Mailbox list appears in a drawer on the side
of the main Viewer window.

If you have more than one account, Mail consolidates (or “merges”)
all mailboxes of a particular type under a single icon in the Mailbox
list. For example, if you have three accounts, Mail displays a single
In box icon; select this icon to list the incoming messages for all three
accounts. If you click the triangle next to the In icon, each account
appears individually; click any one of these icons to display the con-
tents of just that account’s In box. The same holds true for the Out,
Drafts, Sent, Junk, and Trash mailboxes.

Local and Server-Based Mailboxes
If you use POP accounts exclusively, all new personal mailboxes you
create are stored locally and appear at the top level of the Mailbox
list. However, if you have at least one IMAP, .Mac, or Exchange ac-
count, Mail gives you the choice of storing new mailboxes locally
(grouped under an icon labeled “On My Mac”) or on the server. Click
the triangle next to the icon with your account name in the Mailbox
list to see its online mailboxes.

For the most part, the way Mail consolidates mailboxes and distin-
guishes between local and server-based mailboxes makes perfect
sense. This system begins to get confusing, though, when it comes
to mailboxes such as Sent that have a special meaning to Mail. For
example, let’s say you have a POP account and an IMAP account, each
of which has its own Sent mailbox. Mail stores the POP account’s Sent
mailbox locally, whereas it stores the IMAP account’s Sent mailbox on
the server. Mail groups both accounts’ Sent mailboxes under a single
Sent icon in the Mailbox list—with no indication that one of them is
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on your computer and the other on the server. The only way to be
sure whether a given message is stored on the server or not is to select
the IMAP account under the Sent icon and check if the message ap-
pears in that list.

Multiple Users
Mail was designed to be used by a single person, who in turn may
have one, two, or dozens of different email accounts. But unlike
Entourage, Mail lacks anything resembling Identities, which enable
multiple users to have individual mailboxes, address books, and so
on that don’t overlap. If you add an account to Mail for your spouse,
child, or roommate, your mailboxes, rules, preferences, addresses,
and so on will all intermingle. The officially sanctioned way to keep
this data separate for multiple users is to set up a Mac OS X account
for each person in the Accounts pane of System Preferences, and then
configure each user’s copy of Mail for his own email account(s).

There are cases, however, when switching between users, even with
Fast User Switching, is too inconvenient. If this describes your situa-
tion, use the $10 shareware utility MailSwitch (see Appendix A:
Software Sources), which swaps preference files, email folders, and
optionally even address books, without requiring a separate user to
log in. One downside: user settings are not password-protected. So
MailSwitch offers convenience but not genuine privacy.

Fixing a Damaged Mailbox
If a mailbox file on disk becomes damaged, Mail may exhibit any of
several symptoms, including:

• Missing messages

• Incorrect message counts, in which the number of unread
messages shown next to the mailbox name in the Mailbox list
differs from the number of unread messages you see when you
look inside the mailbox

• An empty mailbox, even though you know it contains messages

• Failure to move messages into the mailbox (manually or by using
rules)
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If you suspect that a mailbox contains errors, the standard cure-all
is to rebuild it. To do this, select the mailbox and choose Mailbox >
Rebuild. Rebuilding a mailbox means recreating the table of contents
file that stores a record of its messages. For IMAP accounts, rebuild-
ing a mailbox goes further, deleting all local copies of messages and
downloading them again before recreating the table of contents.

TIP If you want to examine the contents of a mailbox manually (using,
say, a text editor such as BBEdit), look in your ~/Library/Mail
folder. Locally stored mailboxes have the extension .mbox and are
stored inside the Mailboxes folder. POP mailboxes also have the
.mbox extension and are stored in a folder named POP-account-
address. IMAP mailboxes have a .imapbox extension and are
stored in a folder named IMAP-account-address. In each case,
select the file, Control-click (or right-click) it and choose Show
Package Contents from the contextual menu. For .mbox archives,
the file you want to open in a text editor is called mbox; for .imapbox
archives, each cached message is stored as a separate, numbered text
file in the CachedMessages folder.

In extreme cases, if errors persist even after rebuilding a mailbox, you
may need to replace it altogether. To do this, follow these steps:

1. Choose Mailbox > New to create a new mailbox; make sure it’s
stored locally (On My Mac).

2. Select all the messages in the problem mailbox, and drag them into
the new mailbox.

3. Select the old (and now empty) mailbox in the Mailbox list and
choose Mailbox > Delete. Confirm that you want to delete it.

4. Choose Mailbox > Rename to rename the new mailbox so it has
the same name as the one you deleted.

Mail now stores your messages in a fresh, new mailbox.
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HANDLE PREVIOUS RECIPIENTS

Every time you send an email message, Mail updates an internal list
of Previous Recipients with the address(es) you sent it to. Mail’s
Previous Recipients list serves two primary functions:

• It works in conjunction with the Junk Mail filter, preventing any
message from being marked as junk if it comes from an address on
the list. (Mail quite reasonably assumes that you would not send
email to someone from whom you did not wish to receive a reply.)

• It works with automatic address completion to facilitate address-
ing new messages: type a few letters of a name or address, and if
they match an entry in your Previous Recipients list, Mail fills in
the rest of the address automatically, just as if the address were in
Address Book.

In Mail 1.3.9 (included with the Mac OS X 10.3.5 update), the
Previous Recipients list functions more or less as it should. However,
versions of Mail prior to 1.3.8 had a logical flaw in their implemen-
tation of the Previous Recipients list that could cause you to inadver-
tently “whitelist” spammers, thus allowing future messages from
them into your In box. Even if you’ve upgraded to a newer version
of Mail, your Previous Recipients list could still contain problematic
entries. You can clean up your Previous Recipients list so that it be-
comes as useful as possible, or you can change Mail’s settings so that
it effectively ignores the list. Either way, some background informa-
tion will help.

Try an experiment right now. Choose Window > Previous Recipients
to display the Previous Recipients list. As you scroll through this list,
ask yourself what percentage of the addresses you recognize. The first
time I did this, I was shocked to see hundreds of addresses that were
not remotely familiar—addresses I was sure I had never used. If your
experience is similar, you may encounter excess spam, have difficul-
ties in addressing outgoing messages, or even find that some outgoing
email never reaches its destination.

Where did all those addresses come from? Here’s what happens in
versions of Mail prior to 1.3.8. When you move a message from your
In box to a mailbox other than Trash or Junk—whether manually
or by a rule—Mail adds both its addressees and its sender to the
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Previous Recipients list. (Marking a message as Not Junk Mail also
adds the sender’s address to the Previous Recipients list—even in
Mail 1.3.9.) Thus, “previous recipients” was a misnomer, because the
list could include addresses to which you never even contemplated
sending a message.

NOTE Having a clean Previous Recipients list is even more important when
it comes to reducing spam. In Take Control of Spam with Apple
Mail, I discuss the Previous Recipients list as one of numerous
factors to consider when optimizing your Junk Mail filter.
http://www.tidbits.com/takecontrol/spam-Apple-Mail.html

Thankfully, Apple fixed this problem, but there are some others:

• If you mistype an address (causing the message to bounce, or to go
to the wrong recipient), it still appears on the Previous Recipients
list. So the next time you send a message to that person, you could
easily make the same mistake again, if you are using automatic
addressing.

• If you delete or edit an address in Address Book, the old address
remains unchanged in the Previous Recipients list. So despite your
best efforts to keep your records current, you can easily find your-
self sending email to an outdated address.

• You can select an address in Previous Recipients and click Add to
Address Book to add that address to your contact list. However,
doing so always creates a new record; if you have selected a secon-
dary address for someone already in your contact list, you will have
to merge the records manually—even if the names corresponding
to the two addresses were spelled identically.

• Automatic address completion matches addresses in the Previous
Recipients list alphabetically, not according to which one was used
most recently. So if you once sent a message to your friend Phil
using the address phil@aaa.com, then later discovered that his
correct address was phil@zzz.com, the first (incorrect) address
remains the default choice every time you type phil in the To field
from now on.

http://www.tidbits.com/takecontrol/spam-Apple-Mail.html
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If you find the Previous Recipients list valuable for spam filtering or
address completion but wish to minimize the problems it causes, you
can take steps to make it as useful as possible.

Clean up the Previous Recipients list:

The value of the Previous Recipients list increases with the number of
legitimate addresses on it and decreases with the number of inappro-
priate addresses. You can improve the list’s utility by making sure it
contains the right entries. Here are some specific tips to help you
clean up the list of Previous Recipients:

• If you haven’t already done so, use Software Update to install Mac
OS X 10.3.5 (or higher). Mail 1.3.9, part of this update, behaves
better with regard to the Previous Recipients list than some earlier
versions.

• Purge all addresses you don’t recognize from the Previous
Recipients list. (To delete an address, select it and click Remove
from List.) If you should inadvertently delete a legitimate address,
don’t worry: removing something from this list affects neither the
contacts in your Address Book nor sent messages you’ve saved.

• Click a column head to sort by that column; click a second time to
reverse the sort order. (Often, addresses in spam messages don’t
include a Name field. If you sort by name you will group together
all the entries with a blank Name field, making such entries easier
to find.)

• Entries with an address card icon next to the Name field also ap-
pear in your Address Book. (You can even sort by this column, if
you wish.) If you see an address for someone you expect to corre-
spond with again—but without that icon—select it and click Add
to Address Book.

• After adding entries to your Address Book, check there for dupli-
cate contacts. You may need to copy and paste multiple email
addresses for a given contact into a single record manually (then
delete the extra records).

• Be aware that if you’re using Mail 1.3.7 or earlier, filing messages
adds their senders’ and recipients’ addresses to your Previous
Recipients list. If you file a message but want to keep those
addresses from being ignored by the Junk Mail filter, open the
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Previous Recipients list and delete the addresses immediately after
filing a message. (You can sort the addresses by date to help you
find recently added entries.)

• Remember that even in Mail 1.3.9, marking a message Not Junk
also adds its sender’s address to the Previous Recipients list. If you
don’t want it there, remove the address manually.

Turn 0n address display:
To minimize the chance of using the wrong address when using
automatic address completion, you can change Mail’s preferences
so that the email addresses always appear in the address fields along
with the name. To do this, choose View > Addresses > Show Name
and Address. Before sending a message, glance at the address fields
to be sure you have selected the correct address.

Disable Previous Recipients:

I know of no way to prevent Mail from adding addresses to the Previ-
ous Recipients list. You can, however, avoid using the list for junk
mail filtering. To prevent the Junk Mail filter from using Previous
Recipients, go to the Junk Mail preference pane and deselect Sender
of Message Is in My Previous Recipients.

To avoid having addresses in the Previous Recipients list appear when
you address a message, you must disable address completion entirely;
you cannot choose to exclude previous recipients from the address
completion list. To disable address completion, go to the Composing
preference pane and uncheck Automatically Complete Addresses.
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STREAMLINE MAIL WITH RULES

Rules are one of my favorite Mail features; I can’t imagine living
without them. The majority of my rules file messages into mailboxes
so that my In box remains relatively clear, but rules can do much
more than this. You can not only specify complex conditions to check
for, but also set up a rule to take almost any conceivable action when
the conditions are met—thanks in large part to Mail’s support for
AppleScript scripts.

A thorough discussion of rules would require another entire ebook
(click here if you are interested in reading such an ebook). Because
rules are so important, however, I want to touch on a few important
tips for working with them, along with some limitations (and work-
arounds to overcome them). Although most people can put together
basic rules without even looking at the documentation, some features
are less than obvious. (If you’re completely new to rules, choose Help
> Mail Help and search for the topic “Automatically processing email”
or simply click here.)

Rule Tips
From personal experience, I’d like to offer two general words of
advice about working with rules. First, make your conditions as
narrow as you can. The more general your conditions are, the greater
the likelihood that your rules will match messages they shouldn’t.
For this reason, it’s almost always safer to use conditions that look
for address information (To, From, Cc, and so on) than words in the
subject; words in the body of a message are least reliable. Second, go
slowly. After making a new rule, test it for a day or two to make sure
it has no unexpected side effects. Then add new rules one or two at a
time. The vast majority of rule-related problems in Mail result from
rules that conflict with each other (or interfere with the Junk Mail
filter); careful testing can eliminate many such aggravations.

Process repetitive messages
Although this may sound like a no-brainer, I’ve seen lots of people
do exactly the same thing over and over again with certain kinds of
messages. If you find yourself filing, flagging, or deleting a certain
type of message at least once a week, you can save time and effort by
setting up a rule to do it for you. Examples are mailing lists, utility
bills, bank statements, newsletters, travel discount offers, and jokes

file:///Applications/Mail.app/Contents/Resources/English.lproj/MailHelp/pgs/455.html
mailto:jwk@mac.com?Subject=I'd%20like%20a%20book%20about%20Mail%20rules
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forwarded by friends or family members. Remember that filing a
message does not necessarily mark it as unread.

Let Mail fill in conditions for you
Most rules are based on header attributes of incoming messages,
such as the To or From address or the Subject. If you’ve just received
a message and want to create a rule to match future messages like it,
you may be tempted to copy the To or From address (or whatever)
and paste it into the rule’s condition field. Save yourself a few key-
strokes: just select the message in your message list before adding a
new rule. Whenever you choose a header from the pop-up list, Mail
fills in the value of that header for the current message automatically.

Add an “OR” condition for headers
This tip is more advanced. Suppose you want a certain rule to apply
if either the To or the Cc address contains a certain string. You could
enter two separate conditions (To contains xyz and Cc
contains xyz) and use the “Any” option. However, this limits your
flexibility if you want to use other conditions in your rules. For exam-
ple, it precludes you from saying something like “If either the To or Cc
field contains xyz AND the Sender is in my Address Book…” because
that requires using the “All” option to make sure both conditions
apply.

Mail provides a little-known way around this problem. In the first
pop-up menu for one of your conditions, choose Edit Header List.
In the window that appears (see Figure 12), enter To or Cc in the
Header field, then click Add Header. Click OK, then go back to the
same pop-up menu and choose To or Cc. Amazingly enough, Mail
interprets this not as referring to a single “To or Cc” header, but to
either the To or the Cc header. You can use this technique with any
set of headers—“To or From,” “Cc or Bcc,” “From or Reply-To,” and
so on.
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FIGURE 12

You can tell a Mail rule to look for something in more than one
header with a single condition—just add a custom header with the
word “or” between the names of two headers that you want to
match against.

Use different actions for different conditions
Sometimes you want one of two actions to occur, depending on which
set of conditions a message matches. For example, if a message from
a certain mailing list address mentions “Apple,” file it in the Apple
mailbox, but delete all messages from that list without the word
“Apple” in them. A single rule can’t do both, and if a rule files all
messages it matches in a mailbox, no other rule can apply to those
messages. The solution is to have two rules. Use a negative condition
in the first one, and use the second one to move or otherwise process
messages not matched by the first.



Page 84

In this example, Rule 1 might say:

If All of the following conditions are met:

From contains mailing-list-address

Content does not contain Apple

Perform the following actions:

Delete message

This rule weeds out the messages to which the second rule should not
apply. Rule 2, then, might say:

If All of the following conditions are met:

From contains mailing-list-address

Content contains Apple

Perform the following actions:

Move message to mailbox: Apple

Avoid using too many conditions
Because of the way the rules dialog is designed, the number of condi-
tions you can add to any given rule is limited by the height of your
screen—add too many, and you will no longer be able to see the entire
dialog or edit the actions. If you find that a rule uses more than a few
conditions, try splitting it into more than one rule.

Rule Limitations and Workarounds
Rules run on only two occasions: when a new message arrives in your
In box, or when you manually choose Message > Apply Rules. This
design has several implications:

Rules can’t apply to outgoing messages: Mail offers no way
to apply a rule automatically to outgoing messages. Thus you can-
not, for example, automatically file copies of all email you send to
your friend John in a mailbox named John. You can make a rule
that matches messages with your friend’s To address and moves
them to a particular mailbox, but to use the rule, you must select
(some or all) messages in your Sent mailbox and choose Message >
Apply Rules.
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• Rules stop when a message leaves your In box: Mail pro-
vides no way for a rule to activate when a message appears in some
mailbox other than the In box. Once a rule has moved a message
out of your In box, no further rules act upon it—including the
built-in Junk Mail rule. So if you have multiple rules that could
match a particular message, make sure the rules with other actions
(changing color, setting Read status, sending autoreplies, and so
on) are ordered before any rule that moves the message to another
mailbox (or deletes it). In addition, keep in mind that no matter
how many rules you have, your rules can move a given message
only once.

• Mail always uses the entire list of rules: Mail examines each
incoming message to see if it matches the first rule on your list,
then the second rule, and so on until (a) the message is moved or
deleted, (b) a matching rule contains the “Stop evaluating rules”
action, or (c) all rules are exhausted. Although you can reorder
rules or globally disable certain rules, you must apply all active
rules at once; Mail offers no way to invoke just one particular rule
manually. I’ve often wished I could manually select certain mes-
sages and apply a special rule that is not part of the main list, but
Mail can’t do this. If you know some AppleScript, however, you can
create a script that performs the action(s) you want and apply that
script to selected messages manually using the Script menu.

TIP Mail provides no convenient way to create a rule that matches com-
pletely blank messages. If blank email messages frequently clutter
your In box, try setting up the AppleScript solution described in
Appendix B: The Shoot Blanks Script.

• Color-coding bug: Take Control author Jeff Tolbert pointed out
an interesting bug in Mail 1.3.9 that affects those who use rules
to color-code incoming messages. If a rule changes the color of an
incoming message, that color disappears if you later reply to the
message. The problem may be related to the way Mail updates the
message list to include the icon indicating that a reply has been
sent. To reapply the color, you must select the message in the list
and choose Message > Apply Rules. (Remember that doing so
applies all your rules to the selected message.)
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APPENDIX A: SOFTWARE SOURCES

This appendix provides sources and a brief description for the third-
party software that can enhance or supplement Mail. For more Mail-
related software, visit MacUpdate (http://www.macupdate.com/)
or VersionTracker (http://www.versiontracker.com/macosx/) and
search for “Mail.”

Mail Add-Ons
Address Book Importer:
http://www.roydesign.net/addressbookimporter/ (free)
If you need to import contact information from an application that
Address Book does not directly support, export the data as a tab-
delimited text file and use Address Book Importer to convert them.

Emailchemy:
http://www.weirdkid.com/products/emailchemy/ (free)
This utility converts almost any mailbox format (from any platform)
into almost any other mailbox format. It’s useful for importing email
into Mail from a variety of applications.

Eudora Mailbox Cleaner:
http://homepage.mac.com/aamann/Eudora_Mailbox_Cleaner.html
(free)
If you’re moving from Eudora to Mail, this utility painlessly converts
your mailboxes and messages (including attachments!), nicknames,
and even filters to work with Mail and Address Book.

GPGMail: http://www.sente.ch/software/GPGMail/ (free)
GPGMail is a plug-in that enables Mail to work with PGP authenti-
cated and/or encrypted messages. It requires Mac GNU Privacy
Guard [Mac GPG], available from http://macgpg.sourceforge.net/.

HTTPMail: http://sourceforge.net/projects/httpmail-plugin (free)
This plug-in enables Mail to check (paid) Hotmail accounts.

ICeCoffEE: http://web.sabi.net/nriley/software/ (free)
This utility by Nicholas Riley enables you to open URLs in many
applications, including Mail, by Command-clicking them (useful
when composing new messages with URLs). It also gives you access
to the Services menu in contextual menus for text selections.

http://www.macupdate.com/
http://www.versiontracker.com/macosx/
http://homepage.mac.com/aamann/Eudora_Mailbox_Cleaner.html
http://www.sente.ch/software/GPGMail/
http://sourceforge.net/projects/httpmail-plugin
http://web.sabi.net/nriley/software/
http://www.roydesign.net/addressbookimporter/
http://www.weirdkid.com/products/emailchemy/
http://macgpg.sourceforge.net/
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LiSA: http://www.speakingassistant.com/ ($15)
LiSA, the Liquid Information Speaking Assistant, announces incom-
ing messages using a recorded female voice. Each address can have
a different announcement—such as “You have a message from your
boss” or “You have a message from a hot blonde.” This stand-alone
application works alongside Mail or any other Mac OS X email client.

MailEnhancer:
http://home.insightbb.com/~n9yty1/MailEnhancer/ (free)
This Mail plug-in that adds several new features, including a updating
the badge on Mail’s Dock icon to show unread messages in all mail-
boxes, not just the In Box, and enabling Mail to select a signature
automatically based on the address from which you send a message.

MailPictures: http://www.nikwest.de/Software/ (free)
This plug-in was originally designed to provide an easy way to include
your picture in outgoing messages. But as a bonus, it also enables
Mail to send HTML-formatted email. Be sure to download version
3.0, which was in beta as this went to press.

MailPriority:
http://home.tiscalinet.ch/david.frank/projects/mailpriority/ (free)
This plug-in enables you to set priorities for outgoing messages,
color-code messages easily, and request receipts when messages are
received.

Mail Scripts:
http://homepage.mac.com/aamann/Mail_Scripts.html (free)
Andreas Amann’s Mail Scripts are a set of applications, written in
AppleScript Studio, that appear on Mail’s Script menu and add very
useful new features. My favorite: a command to schedule a message
to be sent at the time of your choice in the future.

MailSwitch: http://www.boxorox.com/mailswitch/ ($10)
This shareware utility enables multiple users to maintain separate
preferences and mailboxes in Mail without switching to a different
Mac OS X user account.

MrPostman: http://mrpostman.sourceforge.net/ (free)
This Java application allows any POP client to access email stored on
Web-based services such as Yahoo! Mail, Mail.com, and Hotmail. It
works as a proxy—MrPostman masquerades as a Web browser when
connecting to the Webmail sites, and then you set up Mail to fetch

http://www.speakingassistant.com/
http://home.insightbb.com/~n9yty1/MailEnhancer/
http://www.nikwest.de/Software/
http://home.tiscalinet.ch/david.frank/projects/mailpriority/
http://homepage.mac.com/aamann/Mail_Scripts.html
http://www.boxorox.com/mailswitch/
http://mrpostman.sourceforge.net/
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the messages from MrPostman. It’s not the most Mac-friendly appli-
cation, but it does work. (Hint: Double-click the MrPostman.jar file,
and then choose Help > Using MrPostman for instructions on con-
figuring your email client.) If you need only Hotmail access, though,
HTTPMail is much easier to use.

PGP Mail (part of PGP Personal Desktop):
http://www.pgp.com/products/desktop/personal/ ($50)
PGP Mail is a Mail plug-in that provides encryption and digital signa-
ture features—for both the message text and attachments.

Word Service:
http://www.devon-technologies.com/products/freeware/freeware.php
(free)
This collection of text-formatting commands works with any application
that supports the Services menu. My favorite: a Reformat command to
rewrap paragraphs. Note: Devon Technologies also makes a product
called AntiWordService. Be sure to get the right one!

Anti-Spam Software
For a thorough discussion of these products, read Take Control of
Spam with Apple Mail:
http://www.tidbits.com/takecontrol/spam-Apple-Mail.html.

Junk Matcher: http://junkmatcher.sourceforge.net/Home/
(free; donations accepted)

SpamSieve: http://www.c-command.com/spamsieve/
($25; get $5 off via a coupon in the back of Take Control of Spam
with Apple Mail)

Spamfire: http://www.matterform.com/?page=spamfire/
($25–$40)

SpamSlam: http://www.ilesa.com/ ($25)

SpamCop Bundle:
http://www.subsume.com/assembled/SpamCop.html ($5)

Other Email Clients
Entourage:
http://www.microsoft.com/mac/products/entourage2004/entourage
2004.aspx?pid=entourage2004 (part of Microsoft Office 2004; $399)

http://www.pgp.com/products/desktop/personal/
http://junkmatcher.sourceforge.net/Home/
http://www.c-command.com/spamsieve/
http://www.matterform.com/?page=spamfire/
http://www.ilesa.com/
http://www.subsume.com/assembled/SpamCop.html
http://www.microsoft.com/mac/products/entourage2004/entourage2004.aspx?pid=entourage2004
http://www.microsoft.com/mac/products/entourage2004/entourage2004.aspx?pid=entourage2004
http://www.devon-technologies.com/products/freeware/freeware.php
http://www.tidbits.com/takecontrol/spam-Apple-Mail.html
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Eudora: http://www.eudora.com/ (Paid Mode: $50; Sponsored
Mode: free, but must view ads and SpamWatch feature disabled;
Light Mode: free, no ads, but fewer features)

GNUMail.app:
http://www.collaboration-world.com/cgi-bin/project/index.cgi?pid=2
(free)

GyazMail: http://gyazsquare.com/gyazmail/
($18 shareware; supports POP only)

Mailsmith: http://www.barebones.com/products/mailsmith/
($99; includes free SpamSieve; supports POP only)

Mozilla and Thunderbird: http://www.mozilla.org/ (free)

Mulberry: http://www.cyrusoft.com/ ($36)

Netscape: http://www.apple.com/downloads/macosx/
internet_utilities/netscape.html (free)

Outlook Express: http://www.microsoft.com/mac/otherproducts/
outlookexpress/outlookexpress.aspx?pid=outlookexpress
(free, Mac OS 9 only)

PowerMail: http://www.ctmdev.com/ ($49)

Bulk HTML Email Applications
These applications enable you not only to send HTML-formatted
email (after a fashion), but also to personalize each message in a
manner similar to your word processor’s mail merge feature.

MailDrop:
http://www.freshlysqueezedsoftware.com/products/maildrop/ ($59)

Mail Magic: http://en.infinisys.co.jp/product/mail_magic/ ($18 )

MaxBulk Mailer: http://www.maxprog.com/MaxBulk.html ($40)

Newsletter:
http://homepage.mac.com/julifos/soft/newsletter/ (free)

http://www.eudora.com/
http://www.collaboration-world.com/cgi-bin/project/index.cgi?pid=2
http://gyazsquare.com/gyazmail/
http://www.barebones.com/products/mailsmith/
http://www.mozilla.org/
http://www.cyrusoft.com/
http://www.apple.com/downloads/macosx/internet_utilities/netscape.html
http://www.apple.com/downloads/macosx/internet_utilities/netscape.html
http://www.microsoft.com/mac/otherproducts/outlookexpress/outlookexpress.aspx?pid=outlookexpress
http://www.microsoft.com/mac/otherproducts/outlookexpress/outlookexpress.aspx?pid=outlookexpress
http://www.ctmdev.com/
http://www.freshlysqueezedsoftware.com/products/maildrop/
http://en.infinisys.co.jp/product/mail_magic/
http://www.maxprog.com/MaxBulk.html
http://homepage.mac.com/julifos/soft/newsletter/
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APPENDIX B: THE SHOOT BLANKS SCRIPT

The version of Mail that originally shipped with Panther had an
annoying bug that caused a crash whenever you marked a blank email
message as Junk Mail. Apple fixed this problem in Mail 1.3.7, which
was part of the Mac OS X 10.3.3 update. Nevertheless, some Mail
users continue to receive completely blank messages—without even
a subject or a From address—and Mail’s Junk Mail filter frequently
overlooks them. Worse, there’s no foolproof way to create a rule in
Mail that matches these blank messages and deletes them for you.

There is an elegant solution, however, thanks to David Simerly
(http://homepage.mac.com/beowulf/beoblog/). David devised a
clever AppleScript that deletes blank messages, and you can trigger
the script with a rule. The net result is that you never see such
messages again. David graciously agreed to let us reproduce his
solution here. To eliminate blank messages:

1. Download this AppleScript from David’s Web site:
http://homepage.mac.com/beowulf/.cv/beowulf/Public/Shoot
Blanks.scpt-binhex.hqx.

2. StuffIt Expander should de-binhex the script automatically. After
it does, move the file Shoot Blanks.scpt into
~/Library/Scripts/Mail Scripts. (You should create the
Mail Scripts folder if it does not already exist.)

3. Go to the Rules preference pane and click Add Rule.

4. In the New Rule window, name the new rule Shoot Blanks.

5. Under Conditions, choose Every Message from the pop-up menu.

6. Under Actions, choose Run AppleScript from the pop-up menu,
then click Choose to select that script you downloaded in Step 1
above. (The path should be ~/Library/Scripts/Mail
Scripts/Shoot Blanks.scpt.)

7. Click OK to save the rule, and then drag it to the top of your Rules
list so that it’s the first rule in the list.

This rule now deletes all blank email messages automatically. Note
however, that some messages may appear to be blank but really
aren’t—meaning this script will not delete them.

http://homepage.mac.com/beowulf/beoblog/
http://homepage.mac.com/beowulf/.cv/beowulf/Public/Shoot%20Blanks.scpt-binhex.hqx
http://homepage.mac.com/beowulf/.cv/beowulf/Public/Shoot%20Blanks.scpt-binhex.hqx
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GLOSSARY

authentication: Authentication is the process of confirming your
identity for the purpose of being allowed to use a service. For exam-
ple, when you log in to an account on your Mac, you authenticate
yourself. Similarly, when you supply your user name and password
to a mail server, you are authenticating.

client: A program that works with a server program is a client. For
instance, an email program like Apple Mail is a client that connects
to a SMTP server program to send email and to a POP or IMAP server
program to retrieve email. The computer running client software is
often referred to as a client as well.

data fork: Although this is less common in Mac OS X than in previ-
ous versions of the Mac OS, Macintosh files can be composed of two
portions, a data fork and a resource fork. In general, the data fork
holds data for the file—text, graphics, video, and so on—that could
be relevant to any platform, whereas the resource fork stores infor-
mation that’s relevant only when the file is used on a Mac. (Often this
information is ancillary, but other times it is quite important. For ex-
ample, Classic versions of Nisus Writer store formatting in the re-
source fork.) It’s important that the data fork of an email attachment
transfer properly to the recipient, either along with the resource fork
(when the recipient uses a Mac) or not (for recipients who use other
platforms).

Fast User Switching: Fast User Switching is a feature in Mac OS
X 10.3 Panther that makes it possible for multiple users to log in to a
single Mac and to switch quickly between logged-in accounts. Turn on
Fast User Switching for an account in the Accounts preference pane
in System Preferences: click the Login Options button at the lower
left; then select Enable Fast User Switching. Once you do this, you’ll
notice a new menu at the far right of your menu bar.

hard line break: In typical typing situations, including Mail, when
you press Return, you insert a hard line break. This causes the insert-
ion point to move down to the next line, where you can begin typing a
new paragraph. Technically speaking, a “hard line break” consists of
one or two (usually) invisible characters: By default, Windows uses a
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carriage return (CR) and a line feed (LF) character, Mac OS 9 uses
just CR, and Unix and Mac OS X use just LF.

hijack: Hijacking occurs when someone secretly takes over a com-
puter, either directly over a network connection or via a program that
performs tasks for the hijacker. Most hijackers take over computers in
order to use them as servers for distributing spam, pirated software,
viruses, or pornography.

HTML: HTML, or Hypertext Markup Language, is a tag-based sys-
tem of formatting text for display in a Web browser. For example, the
HTML code <b>Mail</b> would cause “Mail” to appear in bold on a
Web page.

Most ads—and a lot of spam—use HTML, but HTML is also the de-
fault format for several email clients. In these email programs (not
Mail), the formats you apply to messages by clicking buttons or
choosing menu commands go to recipients as HTML. (Typically, you
don’t see HTML when you work in these programs.) Also, some email
programs (including Mail) can display HTML-formatted messages in
a similar manner to a Web page. In practice, HTML implementation
in email programs to date has often been poor.

IMAP: IMAP, or Internet Message Access Protocol, is an increasingly
common way to receive email from a mail server on the Internet.
IMAP typically stores email on the server, making it particularly use-
ful if you wish to access your email from more than one computer.

local: Think of local as meaning “part of your computer.” If you save
an email message to your Mac’s hard disk, you are saving it locally. In
contrast, you can view a message locally (that is, on the computer in
front of you) but save it remotely on a mail server, which could be
down the hall or on the other side of the globe.

netizens: A term for citizens of the Internet.

ping, pinging: A method of communicating on a network that can
be used for several purposes including troubleshooting. A ping is a
short message sent to a computer on a network (such as the Internet),
basically saying, “Are you there?” If all is well, the computer re-
sponds, saying, with another short message saying, “I’m here.” You
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can use a ping to find out if a server is available and to find out
how long it took to reach the server and get a reply. Pinging on the
Internet is similar to using sonar pings to locate underwater objects.

plain text: Text that lacks formatting. If a program saves informa-
tion that you typed as plain text, any formatting, such as margins or
bold, is lost. Plain text is the lingua franca of computer-based text:
almost everything can understand it. Plain text makes sense for email
because you can count on virtually every email program to be able to
display it. Many people prefer plain text to HTML or rich text because
the recipient has total control over how it looks. (Most email clients
enable you to set a default typeface for plain-text messages.)

POP: POP, Post Office Protocol, is a common way of receiving email
on the Internet. Generally speaking, POP-based email accounts store
email on the local computer; whereas IMAP-based email accounts
may store email elsewhere, on a remote server.

protocol: A formal language by which different programs, such as an
email client and email server, communicate. SMTP, POP, and IMAP
are common protocols in the world of email.

resource fork: Although this is less common in Mac OS X than in
previous versions of the Mac OS, Macintosh files can be composed
of two portions, a data fork and a resource fork. In general, the data
fork holds data for the file—text, graphics, video, and so on—that
could be relevant to any platform, whereas the resource fork stores
information that’s relevant only when the file is used on a Mac. (Often
this information is ancillary, but other times it is quite important. For
example, Classic versions of Nisus Writer store formatting in the re-
source fork.) It’s important that the data fork of an email attachment
transfer properly to the recipient, either along with the resource fork
(when the recipient uses a Mac) or not (for recipients who use other
platforms).

rewrap: When text rewraps, it adjusts to a new window or margin
size. For instance, when you are working in Mail, if you change the
window size of a message, the text may rewrap, to better fit the new
window size. See wrap for more information.
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rich text: In contrast to plain text, which stores just the characters
you type but no formatting, rich text also stores formatting such as
type style, colors, and paragraph alignment. Behind the scenes, for-
matting tags (similar to HTML tags) are inserted into the text and
decoded automatically by the recipient’s email client. A properly
composed rich-text message includes a plain-text version, so that it
appears correctly on clients without rich-text support.

Despite the similar name, rich text in Mail is not the same as Rich
Text Format (RTF), a file format invented by Microsoft and used by
applications such as TextEdit. However, some email clients, including
Microsoft Outlook, use RTF for outgoing email (Content-Type:
"text/rtf") and call it “Rich Text.” And, still other applications use
“Rich Text” to refer to HTML messages! Without detailed investiga-
tion, you rarely know what you’re getting when you use rich text.

NOTE If you view the source of a rich text message by choosing View >
Message > Raw Source, you will see a MIME Content-Type of
"text/enriched".

scheme: The first portion of a URL, the scheme, indicates a type
of Internet service. For example, http indicates a Web service and
mailto indicates an email service.

server: A program that sends information to client programs. Email
servers, for instance, work with email clients to send and receive
email. A computer running server software is also typically referred
to as a server.

SMTP: SMTP, or Simple Mail Transfer Protocol, is the protocol used
for sending email on the Internet.

spoofing: Spoofing is the act of sending email with faked header
information, making it appear to come from someone other than
yourself. In the days of Internet yore, spoofing was most commonly
used for jokes. Lately, though, it has become a serious problem,
because spoofing can be used to sneak spam by spam filters and
to more easily spread viruses.
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SSL: SSL, or Secure Sockets Layer, is a security protocol that secures
Internet-based transactions at the program level. For example, most
Web sites use SSL to protect credit card transactions.

subscriptions: In IMAP-capable email programs, the capability to
view only selected mailboxes instead of every mailbox on the server.

wrap: Wrapping happens when a line of text runs into the right edge
of a window. Because it can’t continue to the right, the text wraps
down to the next line. That’s good: if the window size changes, the
text rewraps to align properly with the new window size. However, if
a person (or program) inserts hard line breaks at the end of each line,
then the text can no longer rewrap nicely if the window size changes.
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READING AND PRINTING TIPS

This ebook was designed to be read onscreen or printed. These tips
help you get the most out of reading online and provide advice about
printing.

Onscreen reading tips:

We carefully designed the Take Control ebooks to be read onscreen,
and although most of what you need to know is obvious, note the
following for the best possible onscreen reading experience:

• Blue text indicates links. You can click any item in the Table of
Contents to jump to that section. Cross-references are also links,
as are URLs and email addresses.

• Work with the Bookmarks tab or drawer showing so that you can
always jump to any main topic by clicking its bookmark.

• Find more tips at http://www.tidbits.com/takecontrol/reading-
tips.html.

Printing tips:

Although our layout is aimed at making online reading an enjoyable
experience, we’ve made sure that printing remains a reasonable
option. Please review these tips before you print:

• Use the Check for Updates button on the cover to make sure you
have the latest version of the ebook and to verify that we don’t plan
to release a new version shortly. If you want to commit this ebook
to paper, it makes sense to print the latest possible version.

• Don’t throw out your PDF after you print! You must click the
Check for Updates button on the cover to get future updates. The
link must be accessed from the cover of your PDF.

• For a tighter layout that uses fewer pages, check your printer
options for a 2-up feature that prints two pages on one piece of
paper. For instance, your Print dialog may have an unlabeled pop-
up menu that offers a Layout option; choose Layout, and then
choose 2 from the Pages per Sheet pop-up menu. You may also
wish to choose Single Hairline from the Border menu.

http://www.tidbits.com/takecontrol/reading-tips.html
http://www.tidbits.com/takecontrol/reading-tips.html
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• When printing on a color inkjet printer, to avoid using a lot of
color ink (primarily on the yellow boxes we use for tips and
figures), look for an option to print entirely in black-and-white.

• In the unlikely event that Adobe Acrobat or Adobe Reader cannot
successfully print this PDF, try Preview; several readers have
solved printing problems by using Preview.

WARNING! TURN OFF WEB CAPTURE IN ACROBAT 6 PROFESSIONAL

In Acrobat Professional, set your Web Capture preferences to open
links in a Web browser. Otherwise Web pages will be inserted into
the ebook, and you won't be able to download free updates. To do so,
choose Acrobat > Preferences and select Web Capture from the list of
preference panes. Then, from the Open Web Links pop-up menu,
choose In Web Browser.
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ABOUT THIS EBOOK

Read this section to learn more about the author, the Take Control
series, and the publisher.

About the Author
Joe Kissell is the author of several
books about Mac software, includ-
ing Take Control of Upgrading to
Panther, Take Control of Spam
with Apple Mail, and 50 Fast Mac
OS X Techniques. He has worked
in the Macintosh software industry
for the past ten years, including
positions managing software
development for Kensington
Technology Group and Nisus
Software.

Joe holds the honorary title
“Curator of Interesting Things” at
alt concepts, an Internet publish-
ing and consulting company. He
invites you to read his popular
Interesting Thing of the Day
column at http://itotd.com/.

When not writing computer books or articles about interesting things,
Joe likes to travel, cook, practice t’ai chi, and imitate the “ba-deep”
sounds his TiVo makes. He lives in San Francisco with his wife,
Morgen Jahnke.

To contact Joe about anything in this ebook, send him email at
jwk@mac.com and be sure to include the words Take Control of
Apple Mail in the subject of your message.

Author’s Acknowledgements
The entire group of Take Control authors and editors offered
numerous suggestions and tips that made this a much better
ebook. I especially want to thank Tonya Engst, whose editorial
expertise and long hours of work made this ebook possible.

http://itotd.com/
mailto:jwk@mac.com?subject=Take Control of Apple Mail
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Shameless Plug
Interesting Thing of the Day is
my virtual museum of interesting
things. Every day, I post a new
article that provides a detailed,
entertaining, and educational
look at something interesting.
Topics include unusual or intriguing discoveries in food, travel,
technology, language, philosophy, science, history, and more—there’s
something for everyone. You can even subscribe to the Audio Edition
of Interesting Thing of the Day to get each day’s article as a high-
quality MP3 recording. I put the same care and enthusiasm into these
articles as I do into my Take Control ebooks, and I think you’ll enjoy
them! Please click on over and visit.
http://itotd.com/

Take Control of Panther: The Series
Take control of computing with the Take Control series of highly
practical, tightly focused electronic books! Written by leading Macin-
tosh authors, edited by TidBITS Electronic Publishing, and delivered
to your electronic doorstep within moments of “going to press,” Take
Control ebooks provide the technical help you need.
http://www.tidbits.com/takecontrol/

You may be particularly interested in the following titles:

• Take Control of Spam with Apple Mail, by Joe Kissell
http://www.tidbits.com/takecontrol/spam-Apple-Mail.html

• Take Control of Mac OS X Backups, by Joe Kissell
http://www.tidbits.com/takecontrol/backup-macosx.html

• Take Control of Buying a Mac, by Adam Engst
http://www.tidbits.com/takecontrol/buying-mac.html

• Take Control of Your AirPort Network, by Glenn Fleishman
(comes with a coupon for $10 off IPNetRouterX)
http://www.tidbits.com/takecontrol/AirPort.html

• Take Control of Upgrading to Panther, by Joe Kissell
http://www.tidbits.com/takecontrol/panther/upgrading.html

http://itotd.com/
http://www.tidbits.com/takecontrol/
http://www.tidbits.com/takecontrol/spam-Apple-Mail.html
http://www.tidbits.com/takecontrol/backup-macosx.html
http://www.tidbits.com/takecontrol/buying-mac.html
http://www.tidbits.com/takecontrol/AirPort.html
http://www.tidbits.com/takecontrol/panther/upgrading.html
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